Reply To: Pixel-perfect fonts in 4.1

Forum / NoMachine for Windows / Pixel-perfect fonts in 4.1 / Reply To: Pixel-perfect fonts in 4.1


Did you try to play with the display settings?

While the session is running, open the menu panel and go in Display settings. There are two check-boxes: “Disable network-adaptive” and the “Disable multi-pass”. Be sure both boxes are checked. This will maintain the quality constant and will disable the progressive refinement. You can also play with the display quality. Moving the slider to the right will improve the quality to practically lossless.

The improvements I’m talking about are twofold: first we need to give better quality to text since the first encoding pass. We know what’s text, but video codecs are quite rigid in the way they allow the application to modify the behavior of the encoder. Enabling a feature of the codec often means disabling some other, so to get the best results we should modify the codec, but in this way we would lose the ability to link at run time and use whatever codec is available on the machine or use the HW encoder/decoder on the GPU. Secondly the “lossless” we obtain at the maximum quality is still the result of a YUV color-space conversion. This color-space conversion includes a down-sampling making highly-contrasted foreground/background combinations visually blurry. To solve this we need an additional RGB pass. This additional pass is not ready for the prime-time and we had to disable it in the 4.1 release.