How to specify which network interface not to use in a NoMachine connection

Forum / NoMachine for Linux / How to specify which network interface not to use in a NoMachine connection

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #38936

    I am testing the free server version of NoMachine 7.9.2-1 on an up-to-date installation of Manjaro with KDE desktop. I also have Wireguard running on this machine, which was working fine and I was able to access it remotely prior to installing NoMachine.

    After having installed NoMachine (which worked flawlessly and I am able to access it just fine remotely), I found that I could get a handshake with Wireguard but no access to either internal nor external systems. So basically I can use one or the other but not both. I’d very much like to use both.

    I then noticed that NoMachine had Wireguard’s internal IPs listed as available addresses:

    nx://10.254.a.b (<– wireguard)
    ssh://10.254.a.b (<– wireguard)

    When I turned off Wireguard, these two would disappear. I thought perhaps that it was a coincidence and that NoMachine had set itself up on those IPs somehow, so I changed the config of Wireguard, but it picked up the change and displayed the new IPs as well.

    So my question is:

    Is there a way to specify that some network interfaces are not eligible for NoMachine connections? Or do I need to be setting this up via Virtual Machines or something?


    Hi, this question has already been answered in forums 🙂 Take a look at the following:

    Disable IPv6? Or configure which interface to bind?

    Namely, you can modify the server.cfg to exclude specific addresses

    # Specify the network interface where the NX service will be bound.
    # Populate the field with an IP address or a domain name.
    #NXdListenAddress “”

    A brief intro about the server/node configuration files is here if you are interested:

    The server.cfg and node.cfg files explained


    Hi @Britgirl,

    Thanks so much for your reply! Though I confess I had not found that post, I did find that setting and have been messing about with it. I don’t know if I’ve got a messed up installation or if I’m not setting it correctly, however I cannot seem to get it to make a difference.

    I’m attaching some screenshots. I have updated the NXdListenAddress in about a dozen different ways, to reflect the internal server address without quotes, with quotes, the network device name, a DDNS domain name that resolves to the correct IP (the latter two of which would be the ideal solutions); and even though I save the file correctly and restart the service, it still shows the double set of IPs.

    I also looked for any hint of a profile, but I’m on the free version so I’m not sure I have that available to me.

    If you have any other suggestions, I’m definitely interested in hearing them!

    Thank you so much again. I appreciate you!




    What you reported is not the expected behaviour. A Trouble Report has been opened which you can track here. It will be fixed in one of the next maintenance releases.


Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.