NoMachine audio and mic setup

Forum / NoMachine for Linux / NoMachine audio and mic setup

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #48436
    prakashsinha bayas
    Participant

    Hello,

    In continuous to an earlier post at link https://forum.nomachine.com/topic/garbled-audio-microphone-redirect-2, below revisions help setup both audio and mic for the NoMachine remote client.

    Upon login to a remote system, by default mic is disabled, I enable it.

    Test is with device OpenMove by shokz…

    Default sink is nx_audio_in

    Default source is nx_remapped_out

    With this source, mic is configured correctly. I could record from a sound recorder software. I cannot hear recorded sound.

    I apply below script, 

    pactl -- set-default-source nx_voice_out.monitor
    
    pactl -- set-default-sink nx_voice_out
    
    pactl -- set-sink-volume 4 96%
    
    pactl -- set-sink-volume 5 96%
    
    pactl -- set-source-volume 5 96%
    
    pactl -- set-source-volume 6 96%
    
    pactl -- set-source-volume 7 144%

    I navigate to settings’ interface. I update audio sink to another sink, External Monitor Audio. I could hear recorded sound from external monitor audio. I update sink back to OpenMove by Shokz. I could start hearing audio by this device also. Both mic and audio are functional after this configuration.

    (With updated defaults, audio does bleed from mic into audio sink. I can hear my own voice from this monitor sink at distance.)

    Please find attached configuration files in here with this ticket for introspection…

    thank you.

    #48450
    Britgirl
    Keymaster

    Please include the Linux distribution details and desktop environment to keep everything in one topic. The attachments were not accepted, so the best thing to do is to zip them up and send to forum[at]nomachine[dot]com. Thanks!

    #48527
    prakashsinha bayas
    Participant

    Please find attached zip archive file 20240609.vdi.zip.

    remote Linux distribution is Ubuntu (Ubuntu 22.04.4 LTS jammy). Desktop environment is gnome…

    Thank you britgirl.

    Attachments:
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.