Polkitd slowly consumes memory

Forum / NoMachine for Linux / Polkitd slowly consumes memory

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #12166
    grantroch
    Participant

    I started using NoMachine recently as a remote desktop solution.  However, I noticed that the polkitd process on the server slowly consumes all my RAM. I haven’t made other changes to my system and others in my organization are seeing the same behavior (one person’s polkitd process is consuming 14.5GB of memory, I killed my polkitd when it was 8GB and it is already back to 2.0GB).  Also, from the system monitor the polkitd process CPU usage hovers around 12% but after I shutdown NoMachine that usage goes to 0%.  Any ideas?

    Thanks

    Server/Client are both running Linux Mint 17, MATE 1.8.1, NoMachine 5.1.44 free version

    #12185
    kroy
    Contributor
    #12187
    grantroch
    Participant

    That doesn’t seem to work.  Before anybody connects to the server, the polkitd process sits there at 7.1MB and 0% CPU.  However, once somebody connects and the disconnects, the process consistently consumes 12% CPU and memory increases by .1MB/second.

    #12188
    grantroch
    Participant

    Another thing to note is that even though no client is connected there is a consistent 20KB/second sending and receiving network activity.  Once I stop the server, that activity disappears.

    #12225
    kroy
    Contributor

    Can we see your logs? Please run debug, restart nxserver, reproduce issue and send all logs from server side to forum[at]nomachine[dot]com. You can find instructions about debug and collecting logs here: https://www.nomachine.com/DT04M00076.

    Another thing to note is that even though no client is connected there is a consistent 20KB/second sending and receiving network activity.  Once I stop the server, that activity disappears.

    On server side open NoMachine Player, choose settings. Next navigate to Privacy panel and check “Don’t show other computers on the network”. Then click on Server preferences on the bottom of the window. Then uncheck “Advertise this computer on the network”. Now restart nxserver and recheck network activity. Please let us know here if it helped.

    #12217
    grantroch
    Participant

    I think I figured out some idea about what is going on.  Our home drives are mounted on a central server and the network activity was between my computer and that server.  Looking at a packet dump shows continued attempts to read .config/pulse and .pulse-cookie.  Something, presumably NoMachine, continually tries to do something with these files.  I think unchecked “Use sound notifications when there is an event” and “Enable audio streaming and microphone forwarding”.  Presumably only the first one needed to be unchecked, but after restarting the server, connecting and disconnecting, polkitd continues to have small memory footprint, uses no CPU, and the continuous network traffic is no longer there.

    #12563
    Britgirl
    Participant

    We’ve not been able to reproduce this issue at all. If it’s possible, can you send us the logs from the server? You’ll need to enable logs first, then reproduce. See the instructions here and send them to forum[at]nomachine[dot]com. Thanks.

    https://www.nomachine.com/DT07M00098

Viewing 7 posts - 1 through 7 (of 7 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.