Services won’t start on Fedora 25

Forum / NoMachine for Linux / Services won’t start on Fedora 25

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #13001
    DoctorDan
    Participant

    I’ve successfully installed NoMachine on raspbian and Debian 8.
    I have been unable to duplicate this success on Fedora 25. Desktop is Xfce.

    NoMachine version is free ‘nomachine_5.1.62_1_x86_64.rpm’.

    I’ve followed the instructions in the following articles:
    TR02L04291
    AR03C00168

    and
    I’ve removed and reinstalled the rpm on Debian 25

    and this is the result:
    [root@macbook-fedora Downloads]# /usr/NX/scripts/setup/nxserver –updateNX> 701 Starting update at: Thu Nov 24 10:42:18 2016.
    NX> 701 Updating: nxclient version: 5.1.62.
    NX> 701 Using installation profile: Fedora.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 701 Updating: nxplayer version: 5.1.62.
    NX> 701 Using installation profile: Fedora.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 701 To connect the remote printer to the local desktop,
    NX> 701 the user account must be a member of the CUPS System Group: sys.
    NX> 701 Updating: nxnode version: 5.1.62.
    NX> 701 Using installation profile: Fedora.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 701 Saving configuration file to: /usr/NX/etc/node.cfg.backup.
    NX> 701 Creating configuration in: /usr/NX/etc/node.cfg.
    /usr/bin/which: no konsole in (/usr/local/sbin:/usr/sbin:/usr/local/bin:/usr/bin:/bin:/root/bin)
    NX> 701 Updating: nxserver version: 5.1.62.
    NX> 701 Using installation profile: Fedora.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 701 Saving configuration file to: /usr/NX/etc/server.cfg.backup.
    NX> 701 Creating configuration in: /usr/NX/etc/server.cfg.
    NX> 701 ERROR: Cannot enable systemd service: nxserver.service.
    NX> 701 ERROR: Cannot enable systemd service: .

    I have searched for other information regarding these errors and have found nothing useful.

    Please tell me why this is happening and what to do to fix it.
    Thank you

    #13011
    kroy
    Contributor

    Thank you for reporting. Problem is known, it’s connected with SElinux. Workaround you can find in trouble report: https://www.nomachine.com/TR11N07360. Please follow this TR and use the notify me tool to know when a fix is available.

    #13068
    nole34
    Participant

    I already had Fedora installed and it automatically upgraded to 25.  I followed the advice of

    SELINUX=enforcing
    to
    SELINUX=permissive

     

    I’m still unable to connect and get the following errors:
    The session negotiation failed.
    Error: Frame buffer on server not started: nxFrameBuffer aborted

    #13085
    Britgirl
    Participant

    We’ve checked the workaround just to make sure.

    Did you follow the tip “After changing the selinux settings user should reboot machine and then reinstall NoMachine server”?

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.