Unable to make the local display available or access to the local display is disabled

Forum / NoMachine for Linux / Unable to make the local display available or access to the local display is disabled

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #24455


    Kind of newbie to NoMachine.

    I have a fresh new install of NoMachine server v6.8.1 on a headless VM with CentoOS 6.10 and trying to access it from the corresponding client version on Windows 10.

    The current situation is that no session is started and I am getting the following message:
    “The server was unable to make the local display available or access to the local display is disabled”

    I checked the usual suspect:
    DefaultDesktopCommand "/etc/gdm/Xsession gnome-session"
    and also tried any possible proposed variants with no luck.

    Having got the following message in the nxserver.log file:
    “X Frame buffer failed to start”

    I’ve also executed the procedure described here with no success:
    https://forums.nomachine.com/topic/no-session-on-headless-server (however the “X frame buffer failed to start” error message has disappeared now).

    Note that I had to enable NX user accounts to allow proper authentication, otherwise I was getting authentication error (wrong account or password):
    EnablePaswordDB = ‘1’
    EnableUserDB = ‘1’
    (and then explicitly created a local NX user)

    Any help would be highly appreciated.

    Thanks a lot

    Kind regards




    First let me elaborate on the available options.

    When you have a headless Linux machine and NoMachine free version installed
    and want to have access to graphic environment there are two ways to do it:

    1. You can start it yourself by running the Xserver (like Xvfb) then starting
    the environment (like “/etc/gdm/Xsession gnome-session”) there. This method
    is explained in the article https://www.nomachine.com/AR10K00710.

    2. You can let the NoMachine start its own Xserver on demand or by default.
    If there is no Xserver running on the machine and the server.cfg key
    DefaultDesktopCommand is set properly, during the first connection
    you will be prompted to create and connect to new desktop.

    That said, there are a few things to consider.

    1. The physical desktop itself has to be installed. So like in the example
    you provided (etc/gdm/Xsession gnome-session) both the Xsession script
    and gnome-session have to be present.

    2. When dealing with physical sessions, after changes in system it is good
    practice to restart the nxserver afterwards. NoMachine regularly checks the availability of Xservers but when no Xserver is found after a certain time, it checks at longer intervals.

    # /etc/NX/nxserver --restart

    3. When starting Xserver by hand (like Xvfb in the topic you provided) you
    have to make sure to start it as standard user and avoid starting it as ‘root’.
    That is unless you specifically want to do it, starting graphical environment
    as root can be dangerous. Here it is important to use the same user as the one
    you want to use to connect via NoMachine. When the users are different, please
    make sure that when on “no available sessions” screen the view is set to “All desktops” instead of “My desktops”.

    And additional article that may help: https://www.nomachine.com/AR07Q01037

    If there is nothing that helps in your problem, we could deduce more from the
    NoMachine logs.

    Article on how to collect logs:

    https://www.nomachine.com/DT10O00163 (“How to gather debug logs for support requests”)

    After gathering logs, please send them to forum[at]nomachine[dot]com using the title
    of that forum’s thread as the mail’s subject.



    Hi Mth,

    Indeed adding the line:

    AvailableSessionTypes unix-remote,unix-console,unix-default,unix-application,shadow,unix-xsession-default,unix-gnome,unix-xdm,windows,physical-desktop

    to my server.cfg file solved my issue
    (for some reason there was no such line in the server.cfg file, but only in node.cfg)

    Thanks a lot for your helpful support.

    Have a great day


Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.