JustAnotherLinuxGuy

Forum Replies Created

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • in reply to: NxFrameBuffer error while starting #48453
    JustAnotherLinuxGuy
    Participant

    Yes, localhost is in the /etc/hosts profile by default. I verified, and it is there.

    in reply to: NxFrameBuffer error while starting #48422
    JustAnotherLinuxGuy
    Participant

    We don’t user docker run to start the VM; it’s managed by Cloud Workstations

    So we use a gcloud command to start it, another gcloud command to start a tcp tunnel, then NoMachine to log into the VM.

    We switched to XFCE as you suggested and we still run into an error. I have sent over the logs for review.

    in reply to: NxFrameBuffer error while starting #48398
    JustAnotherLinuxGuy
    Participant

    This time I was able to resolve the permissions error. But I think we are running into the issue you were referring to with GNOME 46.

    Using the gnome-classic command, enabled us to “launch” the VM but it errored out stating falling back to default session and then force closes. I changed the command to gnome-session and that gives us the option to “select a desktop” but none were listed. I have forwarded the logs to your email. Would you be so kind as to take a look and confirm if this is in fact due to using GNOME versus XFCE?

    in reply to: NxFrameBuffer error while starting #48373
    JustAnotherLinuxGuy
    Participant

    You need to set the default desktop to gnome-classic in the config file in order for it to launch properly. Or at least that’s the case for GNOME 42.

    I cleaned up that VM and started over with a brand new install. I am still seeing a permission error, I think this is being generated because we have set NoMachine to create its own X11 display. Which requires CreateDisplay 1 and DisplayOwner "DV9G49". If I understand correctly, this causes a directory to be set up in /rhome/ but due to the permissions of this directory, NoMachine can’t and therefore we see an error.

    However, this time it is not a frame buffer error as before. Can you take another look at the logs to see if there is something different occuring this time around?

    in reply to: NxFrameBuffer error while starting #48367
    JustAnotherLinuxGuy
    Participant

    Perhaps I haven’t been very clear…

    We do not care to set a default home directory. The frame buffer issue was appearing before we had any sort of permission errors.

    Furthermore, I have attempted to disable the configuration for setting a default home directory. Despite numerous attempts, the permission error still remains. Is there a setting I can adjust to prevent the system from making these changes? Please refer to my previous post where I noted the server.cfg change I made in regards to the default directory.

    in reply to: NxFrameBuffer error while starting #48350
    JustAnotherLinuxGuy
    Participant

    I did look through the previous posts, but I wasn’t able to find anything relevant to our setup. I sent over an email with some more info

    in reply to: NxFrameBuffer error while starting #48347
    JustAnotherLinuxGuy
    Participant

    I have attempted to update the setting that prevents this directory from being created. I updated this setting in server.cfg and the relevant setting in node.cfg. But as I mentioned, despite making changes and restarting the service, the permissions error still appears. Why would that be, if I made specific changes on the config files?

    This VM was created using Dockerfile, hosted in Google Cloud’s Workstations (used for VDI).

    Please note, we intend to use /rhome as the main directory, we are mounting this directory to a GCP bucket using Filestore. So the /home/DV9G49 directory is irrelevant to us.

    `root@workstation-analyst3:~# ls -la /rhome/
    total 736
    drwxr-xr-x 15 root root 4096 May 31 14:36 .
    drwxr-xr-x 1 root root 4096 May 31 13:26 ..
    drwxr-xr-x 2 root root 4096 Feb 27 18:39 27M6PF
    drwxr-xr-x 2 root root 4096 Feb 27 18:39 4E37FH
    drwxr-xr-x 2 root root 4096 Feb 27 18:39 8ZC5XJ
    drwxr-xr-x 2 root root 4096 Apr 30 15:57 DMDSX2
    drwxr-xr-x 2 root root 4096 May 23 16:03 DV9G49
    drwxr-xr-x 2 root root 4096 Feb 27 18:39 FKQZ4M
    drwxr-xr-x 2 root root 4096 Feb 27 18:39 GQ4PNR
    drwxr-xr-x 2 root root 4096 Feb 27 18:39 NB87HM
    -rw-r–r– 1 root root 578188 May 31 14:36 NoMachine-log-2024.05.31-13.50.51.zip
    drwxr-xr-x 2 root root 4096 Feb 27 18:39 RB85WW
    drwxr-xr-x 2 root root 4096 Feb 27 18:39 TBS5RZ
    drwxr-xr-x 2 root root 4096 Feb 27 18:39 YXM85D
    drwxr-xr-x 2 root root 4096 Feb 27 18:39 ZXW4NR
    drwx—— 2 root root 16384 Feb 24 15:10 lost+found

    root@workstation-analyst3:~# ls -la /home/DV9G49
    total 28
    drwxr-xr-x 2 DV9G49 DV9G49 4096 Feb 27 14:52 .
    drwxr-xr-x 16 root root 4096 Feb 27 14:52 ..
    -rw-r–r– 1 DV9G49 DV9G49 220 Apr 23 2023 .bash_logout
    -rw-r–r– 1 DV9G49 DV9G49 3526 Apr 23 2023 .bashrc
    -rw-r–r– 1 DV9G49 DV9G49 5290 Jul 12 2023 .face
    lrwxrwxrwx 1 DV9G49 DV9G49 5 Jul 12 2023 .face.icon -> .face
    -rw-r–r– 1 DV9G49 DV9G49 807 Apr 23 2023 .profile

    root@workstation-analyst3:~# ls -la /rhome/DV9G49/.nx
    ls: cannot access ‘/rhome/DV9G49/.nx’: No such file or directory
    root@workstation-analyst3:~#’

    in reply to: NxFrameBuffer error while starting #48340
    JustAnotherLinuxGuy
    Participant

    Hi,

    I have attempted to remove the directory settings in server.cfg. But despite my attempts at doing so, it appears the permissions error is still populating in the logs.

    
    #
    # Set the home directory for NX users. If an empty value is specified,
    # NX Server will create the user's home in the default directory
    # set on the system.
    #
    UserHome ""

    If I’m not mistaken that is the setting I should adjust, correct? I had it disabled (commented out) and then enabled but with an empty value, as shown above. Either way, the permission error still appears in the log. I have even attempted to restart the services using /usr/NX/bin/nxserver --restart but that did not appear to help at all.

    In any case, I have attached the logs, perhaps I am seeing an old message prior to my changes?

    in reply to: NxFrameBuffer error while starting #48336
    JustAnotherLinuxGuy
    Participant

    So what if I tell you (again) that we were seeing the frame buffer error even without the permissions error? What would be causing it then, if the permission error is removed? I have tried removing that directory from the config file, but the error won’t go away for some reason. I will try clearing the permission error and uploading the logs.

    in reply to: NxFrameBuffer error while starting #48322
    JustAnotherLinuxGuy
    Participant

    Hi,

    Do you have any further suggestions on what we can do? We are stuck, and I have not been able to move past this error message and launch the VM

    in reply to: NxFrameBuffer error while starting #48248
    JustAnotherLinuxGuy
    Participant

    Yes I’m aware but that is not the concern I have at the moment. Even when that error wasn’t there, we are still unable to connect to the VM. The only error we could find was: “NxFrameBuffer error while starting” So I know that the directories permission isn’t the cause, as I mentioned, we were seeing the error prior to this permissions issue.

    in reply to: NxFrameBuffer error while starting #48228
    JustAnotherLinuxGuy
    Participant

    Hello,

    I have attached the logs as requested. Please let me know if there is anything else you need.

    in reply to: NxFrameBuffer error while starting #48207
    JustAnotherLinuxGuy
    Participant

    Hi,

    I am not able to compress the directory per the instructions in your KB, running

    sudo tar -cvp --exclude 'cache*' --exclude 'images' --exclude 'temp' -f - path_to_user_home/.nx | gzip -c nxdir.tar.gz

    returns “no such file or directory” Here is how I have it listed, but despite adjusting the name in the above command, I am unable to compress the files or the directory

    drwx—— 11 user user 4.0K Feb 27 20:51 .nx

Viewing 13 posts - 1 through 13 (of 13 total)