8.5.3 update break sound streaming on Slackware 15.0?

Forum / NoMachine for Linux / 8.5.3 update break sound streaming on Slackware 15.0?

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #44216
    Eeel
    Participant

    Hi,

    Unfortunately updating to latest NoMachine break sound streaming to client.

    The setup I’m using on Slackware 15.0 and -current (15.1) is described in this thread https://forum.nomachine.com/topic/message-cannot-find-the-default-environment-please-contact-your-system-administrator-on-latest-slackware

    Previous update works fine.

    I don’t have particular error in system log and I’ve tested combinations of autospawn and DefaultDesktopCommand with no luck.

    I only have <nomachine_8.4.2_1_x86_64.tar.gz> available on local drive, so I rolled back this old working version. If you can provide a link to previous version it is more than welcome.

    I have Slackware 15.0 and Current (15.1) with KDE available to cross check.

    Help appreciated.

    Best,

    #44231
    Britgirl
    Participant

    We’ve tested with the latest 8.5 and the latest Slackware and don’t have issues with sound.

    Are you using Pipewire? Is the Slackware machine headless?

    Please tell us the output of sudo grep Audio /usr/NX/etc/node.cfg.

    I take it that you are using the Free Edition?

    #44229
    kubaszym1
    Participant

    Hi,

    Nothing significant in audio forwarding has changed in the last update. Have you updated pipewire recently? There is a chance they changed something that broke sound streaming in your case. You can check logs on the server side under these paths: ~/.nx/node/C-<display>-<session-ID> to see whether you have any warnings or errors related to audio.

    Regards,

    Kuba

    #44250
    Eeel
    Participant

    Ok I finally manage to find an error message, thanks Kuba to pointing me to the right folder 😉

    With 8.5.3 i have this error message that i don’t have with 8.4.2, in:

    /home/<user>/.nx/M-<hostname>.<domain>-13001-EBB6855A33251194194DDE1C8CB092AB/session

    /usr/bin/pulseaudio: symbol lookup error: /usr/lib64/pulseaudio/libpulsecore-15.0.so: undefined symbol: XSetIOErrorExitHandler

    Message is repeated when user connect with or without the autospawn modification in /etc/pulse/client.conf.

    Btw I did not do any modification to node.cfg or server.cfg after install, only “autospawn = no” to have sound on client.

     

     

    Full log file content:

     

    Info: Slave server running with pid 3101.

    Info: Listening to slave connections on port 25001.

    Info: Starting NoMachine Monitor version ‘8.5.3’.

    Info: Loaded translation files for ‘English’.

    3086 3086 2023-05-15 22:43:01 659.697 OsDetect: Setting os type to ‘Slackware’.

    3086 3086 2023-05-15 22:43:01 659.726 Main: Creating a new connection monitor.

    /usr/bin/pulseaudio: symbol lookup error: /usr/lib64/pulseaudio/libpulsecore-15.0.so: undefined symbol: XSetIOErrorExitHandler

    3086 3188 2023-05-15 22:43:01 852.178 AudioIoPulseaudioServer: Failed to get devices list.

    [05.15.23 22:43:01.861] X Error: 141 141

    Extension:    138 (RENDER)

    Minor opcode: 7 ()

    Resource id:  0x5a002d3

    [05.15.23 22:43:01.861] X Error: BadWindow 3

    Major opcode: 18 ()

    Resource id:  0x5a002d2

    [05.15.23 22:43:01.861] X Error: BadWindow 3

    Major opcode: 4 ()

    Resource id:  0x5a002d2

    3086 3086 2023-05-15 22:43:02 194.063 MonitorService: Enabled drag and drop feature.

    3086 3086 2023-05-15 22:45:32 271.030 MonitorDB: Adding user ‘<my-user>’.

    Info: Audio decoder running with pid 3461.

    Info: Audio writer running with pid 3462.

    3086 3086 2023-05-15 22:45:32 326.697 MonitorDB: There are ‘1’ users.

    [05.15.23 22:45:32.339] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x5a0032f

    [05.15.23 22:45:32.339] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x5a00334

    [05.15.23 22:45:32.339] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x5a00339

    [05.15.23 22:45:32.339] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x5a0033e

    /usr/bin/pulseaudio: symbol lookup error: /usr/lib64/pulseaudio/libpulsecore-15.0.so: undefined symbol: XSetIOErrorExitHandler

    3086 3462 2023-05-15 22:45:32 360.314 AudioIoPulseaudioServerConnection: WARNING! pa_context_connect failed.

    /usr/bin/pulseaudio: symbol lookup error: /usr/lib64/pulseaudio/libpulsecore-15.0.so: undefined symbol: XSetIOErrorExitHandler

     

     

    #44249
    Eeel
    Participant

    Hi Britgirl, Kuba,

    Thanks for feedbacks,

     

    I’m using NoMachine free edition, I’m not using Pipewire and server have a monitor. I’m running KDE and computer start it automatically (runlevel 4)

     

    Slackware is 15.0 with latest updates (including Kernel 5.15.94) and few softwares installed.

     

    NoMachine install:

    1) Extract the archive in the /usr/NX directory:

    # tar -C /usr/ -xzf nomachine_8.5.3.tar.gz

    2) Run the installation script by specifying a different Linux distribution, for example:

    # /usr/NX/nxserver –install slackware

    Then, in order to make NoMachine server and services starting automatically after a reboot, do the following:

    3) Copy the NoMachine init script to the proper place:

    # cp /usr/NX/scripts/init/nxserver /etc/rc.d/rc.nxserver

    # chmod +x /etc/rc.d/rc.nxserver

    4) Edit /usr/NX/etc/node.cfg:

    # DefaultDesktopCommand “env -u WAYLAND_DISPLAY /usr/bin/dbus-launch –sh-syntax –exit-with-session /usr/bin/startplasma-x11”

    # Works fine in runlevel 3 with sound (SDDM/KDE not started):

    # Works fine in runlevel 4 (SDDM/KDE started) with “autospawn = no” in /etc/pulse/client.conf for sound:

    # runlevel configured in /etc/inittab

    DefaultDesktopCommand “/usr/bin/env XDG_CONFIG_DIRS=/etc/xdg:/etc/kde/xdg /usr/bin/dbus-launch –sh-syntax –exit-with-session /usr/bin/startplasma-x11”

    5) Edit /etc/pulse/client.conf

    autospawn = no

     

    My today test: I open Chrome and put Youtube radio, sound output to my headset, I use another computer connect to desktop with an other public IP address or from local network address, sound switch to NOMACHINE when the client connect.

     

    Works fine with with 8.4.2 (i had no issue with the version before 8.5.3, i don’t remember the exact version I was on but i do update every time a new version is available):

     

    ~$ grep Audio /usr/NX/etc/node.cfg

    AudioInterface pulseaudio

    #EnableAudio 1

    # Specify path and name of the command to start PulseAudio server.

    CommandStartPulseAudio “/usr/bin/pulseaudio –high-priority=no”

    DefaultDesktopCommand “/usr/bin/env XDG_CONFIG_DIRS=/etc/xdg:/etc/kde/xdg /usr/bin/dbus-launch –sh-syntax –exit-with-session /usr/bin/startplasma-x11”

     

    Client is connected to desktop:

     

    ~$ pactl list sources | grep NoMachine

    Description: Monitor of NoMachine Output

    device.description = “Monitor of NoMachine Output”

    Description: Remapped Monitor of NoMachine Output

    device.description = “Remapped Monitor of NoMachine Output”

    ~$ pactl list sources | grep nx

    Name: nx_voice_out.monitor

    Monitor of Sink: nx_voice_out

    Name: nx_remapped_out

    device.master_device = “nx_voice_out.monitor”

     

    Doesn’t work with 8.5.3, no sound on client computer. (I did a server reboot just in case after installing 8.5.3)

     

    ~$ grep Audio /usr/NX/etc/node.cfg

    AudioInterface pulseaudio

    #EnableAudio 1

    # Specify path and name of the command to start PulseAudio server.

    CommandStartPulseAudio “/usr/bin/pulseaudio –high-priority=no”

    DefaultDesktopCommand “/usr/bin/env XDG_CONFIG_DIRS=/etc/xdg:/etc/kde/xdg /usr/bin/dbus-launch –sh-syntax –exit-with-session /usr/bin/startplasma-x11”

     

    Client is connected to desktop:

     

    ~$ pactl list sources | grep NoMachine

    Description: Monitor of NoMachine Output

    device.description = “Monitor of NoMachine Output”

    Description: Remapped Monitor of NoMachine Output

    device.description = “Remapped Monitor of NoMachine Output”

    ~$ pactl list sources | grep nx

    Name: nx_voice_out.monitor

    Monitor of Sink: nx_voice_out

    Name: nx_remapped_out

    device.master_device = “nx_voice_out.monitor”

     

    Everything look exactly the same to me, nothing in syslog or any system log that i can see, as soon as i switch back to 8.4.2 it works.

     

    #44276
    kubaszym1
    Participant

    Hi,

    It seems you have a pulseaudio internal issue. Have you tried reinstalling or update pulseaudio to v.16?

    Don’t look at NoMachine Output, it’s used for microphone forwarding. For audio forwarding we just capture data from the default sink and send it to the client side.

    Regards,

    Kuba

    #44287
    Eeel
    Participant

    Hi Kuba,

    I have another computer running Slackware current (15.1) and experiencing the same issue with 8.5.3:

    ~$ pulseaudio --version
    pulseaudio 16.1

    Any advice on where to start to troubleshoot this on my side are welcome.

    I will also ask on the Slackware forum.

    Best,

    #44294
    Eeel
    Participant

    This is the log from the Slackware current (15.1) computer

     

    Info: Slave server running with pid 6685.

    Info: Listening to slave connections on port 25001.

    Info: Starting NoMachine Monitor version ‘8.5.3’.

    Info: Loaded translation files for ‘English’.

    6676 6676 2023-05-17 17:17:12 940.513 OsDetect: Setting os type to ‘Slackware’.

    6676 6676 2023-05-17 17:17:12 940.543 Main: Creating a new connection monitor.

    /usr/bin/pulseaudio: symbol lookup error: /usr/lib64/pulseaudio/libpulsecore-16.1.so: undefined symbol: XSetIOErrorExitHandler

    6676 6739 2023-05-17 17:17:13 154.389 AudioIoPulseaudioServer: Failed to get devices list.

    [05.17.23 17:17:13.163] X Error: 141 141

    Extension:    138 (RENDER)

    Minor opcode: 7 ()

    Resource id:  0x66002d3

    [05.17.23 17:17:13.164] X Error: BadWindow 3

    Major opcode: 18 ()

    Resource id:  0x66002d2

    [05.17.23 17:17:13.164] X Error: BadWindow 3

    Major opcode: 4 ()

    Resource id:  0x66002d2

    6676 6676 2023-05-17 17:17:13 499.373 MonitorService: Enabled drag and drop feature.

    6676 6676 2023-05-17 17:19:09 895.106 MonitorDB: Adding user ‘<my-user>’.

    Info: Audio decoder running with pid 7524.

    6676 6676 2023-05-17 17:19:10 737.349 MonitorDB: There are ‘1’ users.

    Info: Audio writer running with pid 7525.

    [05.17.23 17:19:10.745] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x660032a

    [05.17.23 17:19:10.745] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x660032f

    [05.17.23 17:19:10.749] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x6600334

    [05.17.23 17:19:10.749] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x6600339

    [05.17.23 17:19:10.749] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x660033e

    [05.17.23 17:19:10.749] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x6600343

    [05.17.23 17:19:10.749] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x6600348

    [05.17.23 17:19:10.749] X Error: BadMatch 8

    Major opcode: 62 ()

    Resource id:  0x660034d

     

    I can reproduce the issue on three computers running current 15.1 and Slackware 15.0. Two of them have been fully re installed in the last month, interesting that you can’t reproduce, I don’t see what I can do that can cause this.

     

     

     

    #44298
    Eeel
    Participant

    Having some spare time tonight, I did a fresh Slackware 15.0 install on a spare drive, no package update, just edited /etc/pulse/client.conf (autospawn = no) and installed 8.5.3

    8.5.3 doesn’t stream sound to client

    8.4.2. works fine

    Best,

     

    #44570
    yumpo
    Participant

    Can confirm on 8.5.3 NoMachine with audio from PulseAudio, no sounds go into client machine. Downgrading back to 8.4.2 makes the audio work again. Please fix on the next updates, thank you.

    Host: Manjaro Linux
    Clients used: Windows 11 and Android phone

    #44720
    Britgirl
    Participant

    Everyone,

    here is the Trouble Report:

    Audio is not available in the session with NoMachine server v.8.5.3 on Manjaro Linux and other distros
    https://kb.nomachine.com/TR05U10867

    its fix will be in the upcoming 8.6.

    #44727
    Eeel
    Participant

    Hi Britgirl,

    Thank you for your feedback.

    Best,

Viewing 12 posts - 1 through 12 (of 12 total)

This topic was marked as solved, you can't post.