A simple replacement for seamless ssh -X

Forum / NoMachine for Linux / A simple replacement for seamless ssh -X

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #5633

    Hello, I’ve some issues with using NoMachine (CentOS6 server, OS X client).

    As simple as possible, I just want to use to open an application on the server the same way you would via ssh -X, and running the command.  I do not have (or want) a desktop (Gnome, KDE, etc), or to use X11 on the server side.

    I am using the enterprise terminal version, and have tried a million different combinations using the client software “Custom session” & “Run the following command”, etc.  It’s on a local network, have fully disabled the firewall.

    I get to the Custom session screen, and for simplicity lets say I’m trying to open xterm (which is installed) on the remote.  Nomatter what I do (via SSH, NX, etc), I get “Ooops! The connection with the server was lost.  Error is 100: protocol error”.

    nxserver.log and nxerror.log give no useful information.

    I have searched and tried all of the “headless” configuration options.

    Any pointers appreciated.


    Custom session in floating window mode requires XQuartz to be installed on OS X. You can install it by opening Applications => Utilities => X11 and by following the instructions shown there. More details can be found here: http://support.apple.com/en-is/HT201341

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.