Access to linux instance on AWS

Forum / NoMachine for Linux / Access to linux instance on AWS

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #19312
    jgk
    Participant

    Hi, complete beginner question here:

    I tried to follow this tutorial to access a linux instance with ubuntu 16.04 on AWS:

    https://www.nomachine.com/accessing-your-remote-linux-desktop-on-amazon-elastic-compute-cloud-via-NoMachine

    At the end of the process, when I connect using NoMachine to the instance, Ubuntu asks for a password, even though I am choosing to use an authentication key.

    Connection through putty/ssh with authentication key works fine.

    Any idea of what am I missing?

    jg

    #19316
    kroy
    Contributor

    Hi jgk,

    Are you sure that you have selected the ‘Private key’ authentication and chosen the correct key? The whole procedure of the article was¬†tested many times and we didn’t find the problem.

    #19322
    jgk
    Participant

    Yes, I am pretty sure I have selected private key authentication and have chosen the correct key (.pem)! (and the key works fine for SSH connection).

    The password request comes up at the end, when I reach the remote desktop (screenshot attached).

    Attachments:
    #19325
    kroy
    Contributor

    We see on your screenshot that the authentication via Private Key went well. But your desktop is locked. The system asks for the desktop owner password – it is not NoMachine who asks for a password. You can disable this feature in the Screensaver and Power Management system settings.

    #19347
    jgk
    Participant

    ok thanks. now through with the password, but immediately after I get a black screen!

    I tried following instructions here, but no success: https://www.nomachine.com/AR03P00973

    after stopping the display manager with sudo service sddm stop and restarting the NoMachine server, I then get an error during the connection with NoMachine: “No available sessions on this server” and “The server was unable to make the local display available or access to the local display is disabled”.

     

    #19352
    kroy
    Contributor

    Are you sure that the nxserver was restarted?

    After executing the restart command sudo /etc/NX/nxserver --restart if you connect to the host it should show the message: “Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?”. When you click on “Yes” it should create a new display.

    Have you made all the steps and then it shows the black screen? If yes, it could be because of a wrong DefaultDesktopCommand value. What is your output of the command grep DefaultDesktopCommand /usr/NX/etc/node.cfg? If you installed KDE Plasma you should have: DefaultDesktopCommand “/usr/bin/startkde”. You can change it by editing the key value in the /usr/NX/etc/node.cfg file.

    You can find here more info about connecting to headless systems: https://www.nomachine.com/AR06N00891.

Viewing 6 posts - 1 through 6 (of 6 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.