ActionTec modem/router

Forum / General Discussions / ActionTec modem/router

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #18232
    resanders
    Participant

    Has anyone had any success allowing remote access on a system using an ActionTec modem/router?  The exact specifications of the router are:

    ActionTec

    Wireless 11ac Bonded VDSL2

    Modem Gateway with MoCA 2.0

    Model # T3200M

    The Ubuntu 18.04 computer uses the latest version of NoMachine 6.

    #18244
    kroy
    Contributor

    Have you tried following these instructions https://portforward.com/actiontec/t3200m/ ?

    More details about what default ports are used by NoMachine are available here: https://www.nomachine.com/AR01L00770.

    #18247
    resanders
    Participant

    Thank you for your response.  It did provide some hope; however, I have tried several times to manually set up port forwarding.  And, of course, NoMachine does this automatically upon startup.  I’m wondering if I should manually set up both TCP and UDP.  I’ve continually gotten the error message about not being able to map the port.  In addition, I’ve also edited the NoMachine server.cfg file to make sure certain things are turned on and have found the settings as they should be.  This modem/router is provided by an IP service.  Could it be that the service has configured the device to make it totally incompatible with running a NoMachine server?

    #18263
    kroy
    Contributor

    I’m wondering if I should manually set up both TCP and UDP.

    Setting TCP should be enough.

    I’ve continually gotten the error message about not being able to map the port.

    Could it be a router configuration error? Did you set port 4000? Please check if Firewall isn’t block 4000 port.

    Are you able to open ports for other services – for example SSH?

    #18269
    resanders
    Participant

    In the firewall setting of this particular ActionTec modem/router, there is a long list of ports defined as open to traffic out.  The ones dealing with web service are also checked to allow traffic in.  The list includes the usual default settings for things such as FTP, SSH, etc.  If I wished to open FTP access to the system, I would check the box to allow traffic in.  At the bottom of the defined ports is a setting to allow in and out traffic to all other ports which should include 4000.  I’ve even temporarily checked the boxes there just to check things out.  All that aside, in the port forwarding section the particular needs of NoMachine are defined.  The NoMachine software actually sets this automatically when the server is started, but I’ve also set things up there manually.  And, yes, the server.cfg file has EnableUPnP set properly, and UPnP is enabled in the router.  But, there has to be something in the router that is causing the problem.  I just cannot at this point figure out what it is.

    #18292
    Britgirl
    Participant

    Check the IP on the router and then verify it with link following instructions from https://portforward.com/actiontec/t3200m/ – it’s on right, top corner – External IP: XX.XX.XX.XX).

    If router and IP on sites aren’t the same , you need to contact your provider. Failing that, this feature will help solve the problem: https://www.nomachine.com/FR07J02731 (coming soon).

    #18298
    resanders
    Participant

    Thank you for your response.  I’ve been using Teamviewer to work remotely with a friend that has an ActionTec router.  I assigned him a “static” IP address using DHCP reservation.  Does not that accomplish the same purpose as setting up a static IP on the computer itself?  This particular router was assigned to him by is ISP.  The router he had before worked flawlessly with NoMachine, requiring no special efforts. If the ActionTec does require the setting of a static IP on the computer itself in order to work with port forwarding regardless of DHCP reservation, please let me know.  NoMachine has automatically set up everything else it needs with regards to port forwarding.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.