After update to Windows 10 CU (1703) "No available session on server"

Forum / NoMachine for Windows / After update to Windows 10 CU (1703) "No available session on server"

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #14283

    I recently updated all my computers I support to the Windows 10 CU.

    After performing the install, I’m no longer able to use NoMachine on several of them reliably. I can still connect to the computer reliability, but it will often show “No available session on the server”. The server itself sometimes doesn’t start automatically either. It does work sometimes, after restarting the server.

    Anyone else seen this problem?

    All affected computers are W10 Home with intel GPU. All are running NoMachine 5.2.11.


    Hello TeutonJon78.
    We are trying to reproduce problem which you described. In the meanwhile could you enable logs in server and node configurations file, then restart Windows, and after a while compress var/log directory and send to us ?

    The guide how to collect logs on windows is available here:

    Please send them to forum[at]nomachine[dot]com with
    “After update to Windows 10 CU (1703) “No available session on server” as a title of the mail.

    Thank You


    I saw something similar on 15 machines I updated with CU and NoMachine 5.2.11 quit working except on one that was Win 10 Home–all the rest were Win 10 Pro and quit working NoMachine.  I believe is has to do with the LAS service.  All were running Panda AV free before and after CU update. I believe NoMachine needs to update the App for CU.


    Logs just sent.


    Experiencing the same issue reported by TeutonJon78 after upgrading to Windows 10 Creators Update. Additionally the tray icon is missing although it is enabled in the settings to display. I’ve attempted reinstalling but no luck yet.


    Same problem here


    Hi everyone, just to let you know we are working on a fix. It’ll be released as soon as possible.


    I just downloaded and tested 5.2.21 and it worked correctly on both computers that were having issues. Thanks for the quick fix.


    I installed on 20 machines with the Creators Update and it fixed them all–thanks.

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.