AntiX2usb WAN authorisation failure

Forum / NoMachine for Linux / AntiX2usb WAN authorisation failure


Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #14230

    Sorry if this has already been answered:

    I have built a persistent antiX2usb installation and added NoMachine 32 bit deb to it. Everything works fine on the LAN but not on the WAN which gives “Authentication failed, Please try again”.

    The client host machines WinXP-ProSP3 and Linux Mint 18.1 both connect faultlessly on both LAN and WAN when not booted into antiX so I assume it must be an antiX issue.

    Anyone any ideas as to what I look for in the antiX installation to fix this?

    Is there some subtle difference for authentication if the client and host are not on the same IP segment?

    I am using port forwarding rather than UPNP on the router to attach to the server machines which has proved reliable.


    SOLVED: I copied the WAN client connection file from the client host (in this case Linux Mint 18.1) to the USB instillation of antiX. Then booted into antiX and moved the file to the same directory as the working local client connections on the USB. Selecting it from the “Browse Connections” option in the NoMachine client utility it connected without issue. I then saved everything re-booted and it still worked.

    This needs further testing with other machines and in other places to establish if the client file is indeed portable but it would appear that if a connection file can be generated then antiX behaves as you would expect.

    If anyone can explain what is going on it would be helpful.


    Despite considerable efforts we could not reproduce such a problem. We tried also a persistent antiX2usb 32-bit OS. Are you able to send to forum[at]nomachine[dot]com the two .nxs files (both working and broken ones)?

    Helpful to recognizing the problem would be knowing if your password contains special characters. If you prefer, you can send us this information privately.

    Also, what language do you have set on the system?


    I no longer have the broken .nxs file and since getting it to work I can no longer repeat problem. I suspect that both Antix and NoMachine are innocent and that it may have something to do with my router (Asus RT-N66U) as shortly after getting it to work I had a router firmware upgrade and never saw the problem again.


    Thanks for letting us know. This topic will be closed.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.