Are my settings for connecting over the internet ok?

Forum / NoMachine for Linux / Are my settings for connecting over the internet ok?

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #39211

    I just installed NoMachine on Linux Mint 20.3 and a client on my (modern) Android phone. On the network it worked flawlessly and seems a great app. I can easily view my laptop on my phone.

    Remotely, via the internet, can’t connect via my phone to the (linux) laptop. Started with Error 110, now Error 111. I think it is related to port forwarding and uPNP, but can someone check my settings to make sure at least those are ok?

    Page 1:

    Protocol: NX
    Host: (why doesn’t the app say insert internal/external IP here for clarity’s sake?)
    Port: 4000

    Page 2 (Advanced):

    Port used for communication: 4000.
    Use NAT_PMP or UPnP to mape the port: V (yes).
    Use a HTTP proxy for the network connection: V (yes)

    Host: 87.21… [etc. my external IP] (not sure if this is the external IP location)
    Port: 20536 (port NoMachine itself suggests).

    If your HTTP proxy requires authentication, insert credentials: nothing filled in. No clue what. Wifi password? Laptop password? Router password? Something else?


    Router settings:

    I go to NAT -> Virtual servers and fill in this data:

    Server Name External Port Start External Port End Protocol Internal Port Start Internal Port End Server IP Address WAN Interface NAT Loopback Remove
    NM 20536 20536 TCP 4000 4000 atm0.1 Disable

    Tried UDP/TCP, tried UDP. Nothing works. “ERROR 111: Connection Refused”


    If I look at the NoMachine server on my laptop (which works to connect to locally), it says It never lists the external port though as working. UPnP cannot be enabled on the router. You have to forward manually. But also after seemingly doing that, NoMachine doesn’t show any working port. Commands as sudo /etc/NX/nxserver –upnpmap also don’t work, as in never an external IP is shown.

    Thanks for any help.



    if your computer’s public IP is not displayed in the initial welcome panel, manual configuration of the router may be required (either because the router doesn’t support UPnP or because it is disabled), so that the NoMachine server can be reached over the Internet. We have instructions in our KB on how to enable access to your computer from an external network,

    Check out the tutorial we have as well. When you start a connection, by clicking ‘Add’, you insert only the external IP address and port. See the tutorial, images 11 and 12). There is no need to enter the ‘Configuration’ panel to configure a proxy unless you know what the proxy details are. Have you set up a proxy service? If you haven’t, just ignore that section 🙂

    Protocol: NX
    Host: (why doesn’t the app say insert internal/external IP here for clarity’s sake?)
    Port: 4000

    This is for access to your computer when you are on the same network i.e LAN. You should be using the external IP and port (in your case 87.21…xx:20536) The Welcome panels illustrate what to do 😉 but we will bear in mind your suggestion


    Well, still doesn’t work. Even installed a secondary router with UPnP support and have it alternately enabled and disabled. Still no port visible in the NoMachine server. Port forwarding 24000 (or another, mirrored in the app): no effect. Error 111, always. Local network via phone *again* works fine: instantly it is also seen that this is a “Linux Mint 20.3” laptop.

    ‘There is no need to enter the ‘Configuration’ panel to configure a proxy unless you know what the proxy details are.’

    There is no separate ‘Configuration’ panel; only an ‘Advanced’ section. If that is what you mean, details matter when you write/give instructions. This adds confusion.

    Why don’t I need to enter a proxy? Like 99% of people I sit behind a router (a proxy) on a “residential broadband connection. Your app even says:

    ‘Choose this if you are connecting to a computer on your same LAN or if you are on a residential broadband connection.’

    When I’m on the same LAN, proxy doesn’t have to be used. It works fine without it. So why does it say in your app it needs a proxy to be filled in? What’s the relation to the vague description ‘residential broadband connection’? Sounds like a router of sorts.

    But my router of course doesn’t have an external username and password. So maybe we’re talking more about a corporate network here or something. I can just make no sense of these descriptions.

    I also see additional ports being used by the app? Do I need to forward those too? 4411, 8080?

    Hence, the comment:

    The Welcome panels illustrate what to do.

    I do not agree with.

    Anyway, I can’t get the app to work remotely, also not a new router.


    Nope. Threw open all ports for SSH (22-22) and NX (24000-4000) on both the primary ADSL modem/router as the secondary more advanced router (including the 4411 UDP media port).

    By now NoMachine on my phone can see it involves a Linux machine, but under SSH it says, “Error is 100: Connection timed out”. Under NX it says, “Error is 111: Connection refused”.

    Maybe you understand the issue. I don’t. Maybe it’s something with the proxy. Maybe it’s the provider. I’m out of ideas.



    Just a note, NoMachine free has ssh port disabled.

    Using a proxy in NoMachine is similar to like using a proxy in Internet browser. If you are using it in your mobile browser, then there is no need to enable proxy functionality in the player connection.

    Issue with error 100 and 111 looks definitely related with the port forwarding not correctly set.

    As i understood you have in your setup ADSL (router), I will name it after router1, then you have second router and I will name it router2, and then NoMachine server. So your expected connection should work in the following flow:
    Mobile ( NoMachine player ) 4G ---> router1 --> router2 --> nxserver

    In this situation you will configure port-forwarding twice to be able to be able to access nxserver
    [router1 - publicIP:54000] --forwarded to --> [router2 publicIP:54000] --forwarded to --> [ nxserver IP:4000 ]

    In my example I mentioned for the router2, the publicIP, is the IP that directly communicates with router1, and as well I used port 54000. You can use other port that is best works for you.


    Apologies, I didn’t realise you were using the Wizard on the mobile app to start the connection. The app is not yet aligned with the desktop version, so I confused you no doubt when talking about ‘Configuration’, where you have ‘Advanced’. Also, I mentioned the wrong tutorial. I should have pointed you to the tutorial here: All our tutorials are available in our support section ( of the website by the way.

    Version 8 of the mobile app will be released after we’ve released version 8 for desktop, and so the wizard will be removed and other elements will be improved to make connection creation as seamless as possible.

    I confirm what Fisherman says about SSH. Connections using SSH are not available in the free version.



    Britgirl email:

    “Hi, thanks for all the information and your patience so far.

    “In the Ports panel, nxd is not running. Which means that nxnode is ‘stopped’. So something went wrong, somewhere. I assume you’ve not changed anything in the server configuration file, for example changed any keys in there or inserted anything by hand, or physically stopped the nxd process?

    “So, first we need to get nxd running. Have you already done a restart? Let’s try again anyway. You can try by entering the Ports panel again and clicking on the NX service to configure it via GUI. If that fails, let’s try from a terminal:

    "sudo /etc/NX/nxserver --restart

    “Have you noticed that nxd stays running but then stops? I ask because you said in previous replies that on LAN you can connect ok. This indicates that at some point nxd was actually running. But for some reason now, it’s not. This might explain the two types of error, instead of just one. …”

    Ok, after reading that my NX Node stopped, i tried the LAN connection: it didn’t work for the first time ever! Suspecting I may have accidentally unticked “start the automatic services at startup” (when “the machine starts” -> laptop or the No Machine server/app??), i checked it again, rebooted the No Machine app on the laptop, and got rid of all the extra port forwards…

    Still nothing. Now LAN also doesn’t work!

    So I tried to command you gave: sudo /etc/NX/nxserver --restart


    It said “disabled” a few times. Then went to “enabled”. Next thing you know both LAN and also WAN work. That’s the first time WAN works (had to click through an “authenticity of host … can’t be established. … Are you sure you want to continue?”).

    In other words, it’s still a mystery. But it works. I just have to store that sudo command somewhere I guess.

    Thank you.





    It said “disabled” a few times. Then went to “enabled”. Next thing you know both LAN and also WAN work.

    If it happens again, then logs will be useful. I’m glad it’s now working for you 🙂


    Accidentally clicked the log away. In the interest of science, I tried again. Seems the exact same log:

    NX> 162 Disabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 162 Disabled service: nxd.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxnode.
    NX> 161 Enabled service: nxd.

    Here you have another read-out ofsudo lsof -i -P -n | grep LISTENnow that everything works:

    systemd-r    589 systemd-resolve   13u  IPv4   26493      0t0  TCP (LISTEN)
    kdeconnec   1561              xx   17u  IPv6   37338      0t0  TCP *:1716 (LISTEN)
    nxplayer.  26147              xx  22u  IPv4  255667      0t0  TCP (LISTEN)
    cupsd     111376            root    6u  IPv6  737692      0t0  TCP [::1]:631 (LISTEN)
    cupsd     111376            root    7u  IPv4  737693      0t0  TCP (LISTEN)
    nxserver. 173453              nx   20u  IPv4 1417331      0t0  TCP (LISTEN)
    nxd       173555              nx    3u  IPv4 1417358      0t0  TCP *:4000 (LISTEN)
    nxd       173555              nx    4u  IPv6 1413803      0t0  TCP *:4000 (LISTEN) 173581              xx   15u  IPv4 1413818      0t0  TCP (LISTEN) 173581             xx  16u  IPv6 1417360      0t0  TCP [::1]:7001 (LISTEN) 173581              xx   17u  IPv4 1417361      0t0  TCP (LISTEN)
    nxclient. 173602             xx   6u  IPv4 1413830      0t0  TCP (LISTEN)
    nxserver. 173828              nx   10u  IPv4 1415919      0t0  TCP (LISTEN) 173860             xx   16u  IPv4 1413883      0t0  TCP (LISTEN) 173860              xx   17u  IPv4 1411803      0t0  TCP (LISTEN)



Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.