Attempting to reconnect

Forum / NoMachine for Linux / Attempting to reconnect

Tagged: , ,

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #43100
    USM
    Participant
    Hello, I hope its a nice day for you.
    I currently use NoMachine to connect some Linux Mint desktop on kiosk mode at some Ubuntu VM nopersistent.
    When I close the session with my client, NoMachine attempting to reconnect.
    How Can I skip this option because I had searched in NoMachine documentation but I didn’t find.
    Thx for your answer.
    Attachments:
    #43165
    Britgirl
    Participant

    The image shows that the connection was interrupted, not by you, but because the remote computer you are connecting to was restarted or shut down. Are you maybe rebooting the server when you want to disconnect? If you’re not doing that, this needs further investigation to understand why you are seeing that error.

    The second thing is your question about attempting to reconnect. The client will attempt to reconnect when a networking error occurs, or when the NoMachine server detects a condition requiring an automatic reconnection (like when you reboot the server to apply a change, for example). If the connection was terminated cleanly, then it should not reconnect 🙂

    To disable auto-reconnect – just edit ~/.nx/config/player.cfg

    <option key=”Automatically reconnect to the server” value=”false” />

    #43169
    USM
    Participant

    Hello

    Thx for your answer, I test your advice “To disable auto-reconnect – just edit ~/.nx/config/player.cfg” and that’s working perfectly.

    I will explain my situation, I have 5 Linux Mint on kiosk mode. So these Linux Mint can just click on Firefox and log in on a UDS page. When they log on this page they are redirected (by the nomachine connection) to a No-Persistent Ubuntu VM (created from a template). When they quit this VM, the VM is destroyed. I want than when my user shutdown this VM, they are redirectedto my Firefox page and they can’t view anything about NoMachine.

    Is it possible than when my users closed the VM (the NoMachine connection) than they haven’t any pop-up and instant close the NoMachine application.

    #43170
    USM
    Participant

    It is possible to don’t have the first screen before connection

    And the second screen after disconnection

    #43409
    Britgirl
    Participant

    So these Linux Mint can just click on Firefox and log in on a UDS page.

    Do the users download a connection file which the browser then opens using NoMachine client?

    #43428
    USM
    Participant

    No, this is a basic connection between the user and the virtual machine(with NoMachine client and NoMachine server). The user always remains the same person, but the virtual machine is deleted and created after logging out.

    #43568
    Tor
    Participant

    The client can be configured to ignore errors on disconnection, and that together with disabling the automatic reconnection should do what you want.

    You can test these ways:

    1. Run the player with the --exit-always command line option
    2. Edit the NXS connection file, and set the value “always” to the following key:
    <option key="Close the client application when a single session terminates" value="always" />

    #43570
    USM
    Participant

    Hello,
    Can you give me more informations please.

    Where is the NXS connection file.
    And I don’t understand that “1. Run the player with the --exit-always command line option”.

    Thx for your answer.

    #43577
    Tor
    Participant

    The NXS connection files store all your preferences and they are saved by default in the Documents/NoMachine directory. I noticed my post was corrupted for some reasons and the last line was not visible. Read it again to see the option to change.

    As for the command line option, you can use it by starting the following command in a terminal:
    /usr/NX/bin/nxplayer --exit-always
    Since you’re configuring a kiosk you can edit the script /usr/NX/bin/nxplayer and add the option --exit-always to the last line:
    exec "$NX_SYSTEM/bin/nxplayer.bin" --exit-always "$@"

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.