Audio deactivated with local connection

Forum / NoMachine for Windows / Audio deactivated with local connection

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #17871

    Dear NoMachine community,

    I am using the NoMachine Enterprise Client, because I am not able to install software on this computer without Admin access.

    I use a complex setup to mask SSH as HTTPS and use a SSH tunnel to connect to my computers.

    The setup looks like this:

    nxServer:4000 <-> sshServer localForward 4444 to nxServer:4000 <-> ssh/https mask  <-> https proxy <-> ssh/https mask <-> client on localhost 4444

    I use the recent 6.0.80_1 for all products with Win10 (Win7 gives the same error).

    This setup works without problems, (even with audio) if I install the NoMachine free client with server and everything on the same network where i have Admin access.

    However, if I use the NoMachine Enterprise Client, I can connect to the same server, but I do get the Error “Audio Disabled for Local connections”.

    I found a similar issue here:

    May it be possible that the NoMachine Enterprise client has not implemented the above bugfix?


    Audio is Important for me to listen to my synths from anywhere 🙂


    Thank you for this awesome software, Louis


    We aren’t able to reproduce this problem.

    Can you enable debug on the server side, restart nxserver and reproduce issue?

    Please send server side logs and player logs from the client side (it’s folder started with “R-“, which is in .nx folder in the user’s home directory). Instructions about debug and collecting logs you can find there:


    I enabled the options following the page you linked.

    However there are all sorts of private informations within the log files. Would it be possible to email or transmit you the logs directly so that they are not avaliable to the public?

    Thank you, Louis


    You can send them to forum[at]nomachine[dot]com making sure you reference the topic in your email 🙂


    Thanks for the report. Issue will be fixed as soon as possible. Please follow this trouble report: and use the notify me tool to know when a fix is available. As a workaround you can open cmd on the client side (you don’t need administrator privileges), navigate to NoMachine Client installation directory (in default NoMachine folder is created in the home directory) and execute command:

    bin\nxkeygen.exe -u > etc\uuid

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.