Audio issue: Speaking into microphone is choppy

Forum / NoMachine for Linux / Audio issue: Speaking into microphone is choppy

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #41379

    Hello everyone!

    I’ve had a problem for a while that I can’t find a solution to. After connecting to a remote Terminal Server (version 7.10/8.2) on a Debian 10 machine, and creating a virtual desktop.  I try to record myself speaking, but the audio is choppy (part of the audio was lost/dropped). I’ve tried different Linux distros:

      • Fedora 35
      • Ubuntu 22.04.01
      •  Manjaro 22.0

    All distro were tested with  NoMachine Enterprise Client 7.10 and 8.1. Regardless of the version, the problem persists among all of them. However, the problem only happens when I’m using a machine running Linux. The problem doesn’t occur when I connect to the Terminal servers with a machine running windows 10/11 or macOS.

    I’ve taken a recording on the local machine (with audacity) not inside of a NoMachine virtual desktop instance, the problem did not occur, so it’s not an issue with the microphone, input level or local sound server. This was conducted on different hardware.

    To make sure it isn’t a network issue, I’ve done a recording outside of the NoMachine instance on an internet service ( which allows audio recording. That also resulted in no problems, similar to the tests conducted locally using audacity.

    Once these tests were done inside of the NoMachine virutal desktop instance, the audio was choppy and parts of the recording were lost/dropped, the rest is clear. It’s not simply a delay issue, more like some packages are just lost and then the audio stream continues.

    I’ve checked the sound servers running on the Linux machines, using the command: inxi -SAMaz

    Here is the output from the Ubuntu machine.


    Kernel: 5.15.0-43-generic x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15.0-43-generic
    root=UUID=6e0bad13-673b-4d6e-9977-397dc28b177b ro quiet splash
    Desktop: Xfce 4.16.0 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: Ubuntu 22.04.1 LTS (Jammy Jellyfish)
    Type: Laptop Mobo: sharevdi model: HK-BDW01 serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: 5.011 date: 03/18/2022
    Device-1: Intel Broadwell-U Audio driver: snd_hda_intel v: kernel
    bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
    Device-2: Intel Wildcat Point-LP High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
    Sound Server-1: ALSA v: k5.15.0-43-generic running: yes
    Sound Server-2: PulseAudio v: 15.99.1 running: yes
    Sound Server-3: PipeWire v: 0.3.48 running: yes`


    All of the machines are running PulseAudio and Pipewire. When I check which of the Sound Server is currently in using the command:

    pactl info | grep “Server Name”

    I get this as the output: Server Name: pulseaudio

    I’ve struggled with this problem for sometime now, any advice/method to resolve this problem is greatly appreciated.


    Same issue on a fresh install of Ubuntu, should be 22.04.
    No issues with audacity

    Which logs are that in the .NX folder, so you can get a idea?

    Those seem to be only logs and config, where is the actual audio logic stored?

    Much appreciated.



    On debian derivatives the issue goes away if one starts pavucontrol and keeps it running in the background.

    As soon as pavucontrol is exited, the issue appears again.

    We tested this with ubuntu 22.04 and antix. On fedora 35, this workaround did not help.


    Did you all update the latest 8.3 version we released last week? It includes some improvements to audio in general.


    I can confirm that after upgrading to the latest version (8.4.2) on server and client, the issue disappeared. Thank you for fixing this.


    Thanks for letting us know.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.