Authentication failed from another Windows 7 client

Forum / NoMachine for Windows / Authentication failed from another Windows 7 client

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #4686

    I’m changing my laptop to another Windows 7 NoMachine client. I installed the same version of NoMachine 4.0.360 as the working one. The new laptop cannot connect to the same server while the old one can. I used the same OpenSSH tunnelling, i.e. “ssh -L 4555:localhost:4000” and the same NoMachine server. The old client connects fine. But the new client failed the authentication.

    I see the following error logs from nxserver.log when the client failed authentication:

    15:54:00:914.717 NXSERVER-4.0.360[24565] ERROR: Reached timeout of 20s while trying nxexec authentication for user ‘jmi’, to ‘’, port ’22’.

    15:54:00:916.144 NXSERVER-4.0.360[24565] ERROR: process with pid ‘24799’ has died because signal: 9

    15:54:00:916.339 NXSERVER-4.0.360[24565] ERROR: Error while trying to authenticate user:jmi. NXNssUserManager::auth returned 1

    15:54:00:916.525 NXSERVER-4.0.360[24565] ERROR: wrong ‘nxexec authentication’ for user ‘jmi’ from ‘’.

    Anything I missed from client or the server?

    Thanks in advance for any help,



    Can you upgrade to the latest version? A lot of fixes have been released since 4.0.360. Let us know if this helps.


    I changed the TCP port in SSH tunnelling and NoMachine client connection configuration from 4555 to 4556 for my new laptop client. The authentication then worked. I guess the server somehow remembers the port 4555 is for the connection for another client machine.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.