Authentication failed – Mac using AD username/password

Forum / NoMachine for Mac / Authentication failed – Mac using AD username/password

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #15265

    When trying to connect to my Mac I am entering my domain username and password into NoMachine client.

    I get an error “Authentication failed, please try again”

    I am 100% certain the credentials are correct. I have tried typing the username in various formats…





    None work.  am able to authenticate using credentials of a local administrator account on the Mac. Why won’t domain credentials work?


    Hello antonioking,

    Please follow these instructions to help us understand your issue:

    1. Open terminal on your Mac OS X host on some other non-root account. Check if ‘su <problematic_user_name>’ command
    works correctly.

    2. Recreate the issue, and collect sever-side logs from Mac host according to

    In terminal, from root account run: ‘grep nxexec /var/log/system.log > nxexec.log’.
    Send NoMachine server logs and nxexec.log file to forum[at]nomachine[dot]com.


    Hi Cato

    Thanks for responding, and apologies for the tardy response.

    I’m not familiar with the “su” command. However, when I ran it with “the problematic user” I was prompted to enter a password. So I am assuming the command is working as expected?

    In regards to point 2. Where do I find the Server logs or nxexec.log?



    I’m following the instructions on the link you posted, however, the instructions appear incomplete or incorrect.

    At point 3.1 it asks to compress the log folder by right or ctrl clicking the folder and clicking”Create Archive”. I do not have this menu option.

    The alternative is to run a command. The first line:

    $ cd /Library/Application Support/NoMachine/var/” generates an error “command not found”




    Hello antonioking,

    Command ‘su <user_name>’ should result in changing current user with the one passed to command. If it’s not possible for you to authenticate using this command, it’s likely that authentication issue is unrelated
    to NoMachine.

    This command: ‘grep nxexec /var/log/system.log > nxexec.log’ will generate nxexec.log file in current directory.
    You can create archive of your log files by running from terminal (as root):

    tar -zcf mac_os_server.tar.gz /Library/Application Support/NoMachine/var/log’

    This should generate mac_os_server.tar.gz in current directory.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.