Automatic updates doesn’t stay checked

Forum / General Discussions / Automatic updates doesn’t stay checked

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #5835

    I have NoMachine on several machines with Kubuntu 14.04, Windows 7, Windows XP, and OS X 10.10 and all (with the possible exception of the OS X) have the same odd problem: (Note, this has been a problem for the past several versions at least. Currently manually updating to 4.4.1)

    When I select “Automatically Check for Updates” in hope of keeping them all synced (since they crash if they get far enough out of sync) the check box doesn’t always stay checked.

    At times it’s stayed checked for a while, then I come back a day later or a week later only to find that it’s unchecked again. I’ve attempted to do it with “Changes Enabled” or “Changes Disabled”. I even tried enabling changes, checking the box, then disabling changes. Nothing seems to consistently work to convince NoMachine that I really mean it when I say I want automatic updates.

    If this were one computer, or even just one OS, I’d think perhaps I had a permissions problem or (in the case of Windows) a virus. But… Yeah, I’m a bit confused by this one. Does the feature simply not work right?

    Thanks in advance for any insight you may have on the matter. It’s a really frustrating problem with an otherwise very useful tool.


    Hello noahy.
    Currently Software Updates are in beta, so enabling the automatic update option is not allowed. It must always be run manually. Sorry for not making this more clear.
    The good news is that we’re very close to a release supporting Software Updates, we’re currently working on our infrastructure.


    Hi Tor,

    Thanks for the clarification. It would likely be preferable to not show the check box until it does something though, but it’s nice to know that I’m not just going insane. ๐Ÿ™‚

    That said, is there a ticket for this that I can monitor somewhere? We’ve found NoMachine quite nice in almost every other regard, but this has been a real hassle to maintain with a group of non-tech-savvy end-users.


    Hi, we’ve inserted an FR: ๐Ÿ™‚

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.