Big Sur client displaying blank and upside-down

Forum / NoMachine for Mac / Big Sur client displaying blank and upside-down

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #34463

    Howdy, I’ve read a couple topics on this other folks have posted, but their solution did not work for me. I’m attempting to connect to my OSX Big Sur machine from my Windows 10 machine and it perpetually displays a blank login screen with only the menu bar visible, only it’s flipped and at the bottom. If I click around, the menu bar will update and display the names of various apps I’m clicking on (upside-down of course), but I cannot see anything.

    I already went through the processes to provide NoMachine with the proper permissions, the problem persists. I appreciate any help provided.


    Hi Ultric,

    In order for us to investigate, can you please send us server-side logs with debug enabled? We will need you to enable debug, restart nxserver and then reproduce the issue and collect the logs.

    You can see the following article for guidance:

    Please send them directly to us via email to forum[at]nomachine[dot]com and we will take a look. Please use the title of this topic as the subject of your email. Thanks!


    I had the same issue. What fixed it for me was to go to:

    Server Settings > Status > Restart the Server

    Once the server was restarted, a pop-up came up requesting permissions for “nxnode” to access Screen Recording. I allowed that and it all started working.

    Worth noting that “” was already listed as allowed for Screen Recording, which was triggered either during installation or first time run, I can’t recall at the moment. But “nxnode” was only triggered after I restarted the server.

    Lastly, for our good folks at NoMachine to evaluate, everything had been working well for me on Big Sur and all of a sudden it stopped working. I manually added “nxnode” to Accessibility permissions too, again in addition to “”, but what did the trick was restarting the server and allowing Screen Recording for nxnode.

    Hope this helps!!


    Hi Gus,

    thank you!

    The upside-down issue is related to this article: How to use NoMachine v. 6.8.2 or later on macOS Catalina

    Did you do an update on the system or NoMachine? Or did you do something else that might have had an impact on the operating system security permissions?


    Hi Carin,

    Indeed, I had NoMachine (latest release) working fine on macOS Catalina, and started having issues after I upgraded to Big Sur.

    I wasn’t expecting the change in permissions after the upgrade, which caused me to wrongly assume there could be an interoperability issue between the latest NoMachine and Big Sur, but after I made the changes I described in my original post, it all started working again.

    I did follow the steps in but ultimately what resolved the issue for me was to stop the server service and then restart it, which triggered the requests for permission for nxnode.

    Thanks to the community and the NoMachine team for the wealth of information that put me in the right direction.


    Big thank you to @Gus!   You were correct.  Needed to shut down and restart the NoMachine server to be prompted to re-add permissions to the MacOS.


    I had this same issue on NoMachine 7.6.2 after upgrading from Big Sur 11.5.2 to Big Sur 11.6.  Restarting the server did not lead to a permission prompt for me or otherwise resolve the issue. However, disabling “Use hardware encoding” and “Use acceleration for display processing” in the performance section of the server settings made the screen come up normal after a server restart. Because I wanted to investigate further what was causing the problem, I re-enabled both settings and restarted the server again.  When I reconnected again, it was still working normally.


    Hi nxmac,

    You can take a look at the article below:
    How to solve blank/upside down screen on macOS after the update to Big Sur

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.