Black screen on connect

Forum / NoMachine for Windows / Black screen on connect

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #28301

    I receive a black screen on connect.  This is remote/ different location.  This worked just a week ago.  Windows 10 suddenly complained that version was not 64 bit compatible so I uninstalled and re-installed.  Hardware accel is turned off.  The remoter machines are Lunux/Ubuntu headless and a Windows 10 laptop – BOTH have the same exact display issue. Looks like it connects but I receive no video.   Is there something that needs to change in the router/gateway to allow return video?   My router needed to be swapped out, I fixed the port forward



    The latest version is what caused the problem.  I completely removed/uninstalled the latest version and found a very old version 5.1.62_1 and it runs correctly – something with the new version is not right.

    as previously stated, Ubuntu desktop with dongle on video card.  Laptop with Windows 10 (upgraded from windows 7) both worked prior to latest version on my Windows 10 desktop (across town) connecting to both machines remotely – now works

    Free version.

    Not sure what you need from me to help find a fix.


    The latest version is what caused the problem.

    Do you mean latest 6.11.2 or any version before that?

    If the issue is present with version 6.11.2, would you try to reproduce again and send us the logs for debugging? You can find instructions in (for server side logs) and (client side). You can send everything to forum[at]nomachine[dot]com.


    Sent logs – not much in them.  The remote machines will be a little tougher to get the logs.

    1. Removed 5.1.62_1

    2. Installed 6.11.2_

    same behavior as before – black screen

    3. saved logs / sent as requested

    4. removed 6.11.2 – reinstalled 5.1.62

    5. screens display correctly from linux and windows clients (remote boxes)



    We received the logs, but there are no logs from the server side. We would need those (from the machine that you are connecting to) to understand what is happening.

    Can you tell me what version you were on before you updated to 6.11?


    Not sure of prior version – but re-created with good connect on 5.1.62,  then installed 6.11.2 and duplicated the blank screens – removed the 6.11.2 , installed the 5.1.62 again and I am working correctly.   I will be sending logs from Windows and Linux machines


    How to download older version?


    @rsperson, we got the logs, thank you, but they were no actual error logs. Nevermind. Let’s assume it’s this known problem:

    Please try the following known workarounds: either disable hardware decoding on the client (see image here: or try the one in the Trouble Report (server-side).


    reinstalled 6.11.2 – followed workarounds – same problem – no screen echoed back.

    removed 6.11.2

    reinstalled 5.1.62 – works fine


    The only way we can help is to insist on receiving the logs from both client and server sides, with debug enabled.

    – on the connecting client, follow

    – on the computer you want to connect to, follow

    – reproduce the problem

    – gather up logs and submit as before


Viewing 10 posts - 1 through 10 (of 10 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.