Black Screen & Oops + rendering issues on Red Hat

Forum / NoMachine Terminal Server Products / Black Screen & Oops + rendering issues on Red Hat

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #18615

    I’ve installed the evaluation version of Terminal Server Enterprise Edition v6 on Red Hat Enterprise Server 7.3 (in a VM).

    However whenever I try to create a session (e.g. a console) via the Web Tools, I get a black screen and a Oops warning, and what appear to be rendering issues on the screen (see screenshots attached). When I click what would appear to be the ‘OK’ button on the window in focus I then get logged out of the Web Tools interface, and the process gets repeated.

    X11 is installed on Red Hat Linux and appears to be working fine, if I run the following:

    grep CreateDisplay /usr/NX/etc/server.cfg

    I get a response of:

    CreateDisplay 0

    Has anyone seen this issue before with RHEL 7 and Terminal Server Enterprise Edition v6? Are there any logs in particular I can check to see why I’m getting the rendering issues in the Web Tools interface?




    Hi David,

    Regarding the (missing) error messages: I had a similar issue on CentOS when I installed KVM which did not show any text. The reason was a missing font and I was able to solve it by running
    yum install dejavu-lgc-sans-fonts

    If this works, we should be able to see what Error2 says.



    Hi David,

    as for the missing text in the error message, I can try to guess that it is about “can’t start command”. If you are using a custom command, are you sure that you’re writing it correctly or that it is in the PATH or even installed?

    Given also the missing fonts, it seems like you don’t have a complete graphical environment installation on the server. Is that a possibility?



    This issue has been resolved in that I can now read the message, which was advising that there’s no desktop environment installed on the server to open the ‘console’.

    However, I’ve now got a different issue, but I;; post this under a different thread.

    Thanks for all your help with this thread.




Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.