Broken Pipeline / Cannot write to FD#29

Forum / NoMachine for Linux / Broken Pipeline / Cannot write to FD#29

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #38911

    I’m using NoMachine in headless mode on a ubuntu server for ~1.5 years. Now it starts to do strange things, but I hesistate to restart it because users are still logged in.

    I (and others) cannot create new sessions on the server. in Server.log I get (default debug level right now, can do other as well):

    ERROR! Received error message from node ‘localhost:4000’, ‘The remote application terminated unexpectedly.’.
    WARNING! Cannot write to FD#29.
    WARNING! Error is: 32, ‘Broken pipe’.

    I will send the logfiles to forum[at]nomachine[dot]com after this post.

    Best, Benedikt



    Hi, it’s strange that after 1.5 years of working perfectly that your NoMachine server suddenly starts doing strange things 🙂 That can happen if you have changed something on the headless Ubuntu host, like updating it or changing some configuration perhaps?

    I (and others) cannot create new sessions on the server.

    What desktop environment are you trying to connect to? Does this mean that you can reconnect sessions already created before the problem started, and that it’s only new sessions which are not possible?

    I noticed from the logs that you are running a licensed Small Business Server. This means that you are entitled to receive technical assistance from our support team. Since the forums are public, it might be better to open a ticket and have our support team investigate directly. This will also avoid any sensitive information being accidentally published here. Full debug logs will be required, the ones you sent to us don’t appear to be the full set.


    Thanks for the response. I will open a ticket then 🙂

    To answer your questions here:
    1) ubuntu session, but doesnt really matter, others dont work either
    2) yes, some sessions are established already and we can reconnect and only new sessions dont work
    3) nope, no updates, I try to update every few months as a server restart is typically necessary 🙂 At some point, disc space was running low, but that is fixed now. I do have the problem that the nvidia graphics driver stops working after some time, but havent found energy to investigate that. Given it is a live server, that makes such searches difficult


    Finally, when writing the support ticket I noticed I used nomachine *.7 something, instead *.9 – I updated and in that way had to restart the server.
    Now login works again, we’ll see what happens in the future.

    Cheers, Benedikt


    Just to clarify a small detail. When you mention NoMachine session, which is on Ubuntu, knowing which desktop environment you are connecting to is useful for us. By “desktop environment” I mean KDE, Gnome or any other. OK, thanks for letting us know that the problem is solved. If it happens again, by all means open a support enquiry.


    ah sorry, we use Gnome

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.