Cannot assign requested address

Forum / NoMachine for Linux / Cannot assign requested address

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #30551

    Oooof… I mean Hi!

    I was going to ask about performance issues I’ve been having on windows to a vm, but today the nx server “crashed” my host server.
    I woke  up to X11 behaving erratically, not letting me resize windows yet allowing me to start and stop programs, took a look at the journal and saw something like:

    nxexec: pam_unix(nx:session): session opened” followed by

    nxexec: pam_unix(nx:session): session closed

    It was being spammed really fast repeatedly.

    Killing the server solved the X11 issues, but then I couldn’t restart it.
    I was going to just update to the latest version (or at least do a clean install), I’m on version 6.12.3, but seems to be down.
    (system info: OpenSUSE leap 15.2, using KDE)
    Anyway I’d gladly follow the rule “Please also avoid copying long logs and use attachments instead.”
    But when I took a look at the nxserver.log and nxerror.log, good god!
    nxserver.log has 7613394 lines, and just about 7488541 erros, so yeah they are 900 and 881MB respectively.

    nxerror.log shows an error every 0.005 seconds or between 9h50m10s and 9h50m11s it logged 19657 errors.
    The main message in the nxerror.log is:WARNING! Can’t resolve IPv4 host ‘localhost’
    main message in the nxserver.log is:NXSERVER ERROR! Cannot start listening on server daemon socket

    I suspect it has to do with the fact that I made some changes with wicked and made a bond team of two NICs, I had to start it up since it’s not normally on (the system usually use networkmanager)
    Now I’ve turned off the the bond, shut down wicked and made sure netwrokmanager is running normally.
    I still can’t seem to start the nxserver on the machine, everything else is working as expected, I’m not seeing any obvious errors.
    Is there a way that I could investigate further what is causing NX to fail to “resolve localhost”?
    And why did it log 1.7GB of errors before finally making the system unstable
    (I think that’s the cause of the “swap” being full even though there’s 10GB of memory left out of 64GB)

    I think reinstalling NoMachine will solve this (once the site is up and running), but I wouldn’t mind getting some pointers where to look for the cause of this crash.

    I’ve included two pictures one showing the logs, the other showing the network setup where the top is showing how the failing host is set up, and the bottom is basically an identical server set up in the same way, except it gets internet from the failing host.

    Sorry if I’m a bit incoherent, but I haven’t even had my coffee yet.

    Mvh Gatos


    I figured the problem!

    It ended up being just the file /etc/hosts causing the real issues.
    Apparently using “systemctl start wicked” wrote over “/etc/hosts”, where was over written with: host
    instead of: local host
    thanks for the 1.7GB log,seriously nobody though about it?

    “can’t resolve localhost”
    ping localhost… is it no?! “please log this 16000 times “no resolve””
    host? no this can’t be localhost it’s not on the “look up table for localhost that is”


    Hello Gatos,
    NoMachine server needs to be able to resolve localhost.
    Usually when this is not possible, NoMachine prints that during the installation process for example:

    NX> 500 ERROR: Cannot start NoMachine server. Resolve ‘localhost’ is
    NX> 500 ERROR: not possible. Please check settings in the system
    NX> 500 ERROR: hosts file or contact your system administrator.

    But in your case the issues appears after the successful installation so it is not obvious what is going on.

    We confirm the problem of producing redundant error message while
    searching for free ports. The Trouble Report opened to handle this
    issue is: TR12R09936.

    It looks like we have also a problem with repeated restarting of
    NoMachine server daemon. TR about this problem is: TR12R09937


    Hello Gatos,
    After further investigation and tests in our labs, we verified that the nxserver daemon
    has been restarted five times only. This is also confirmed by your logs.

    Five attempts to start the nxserver daemon is the expected behaviour, therefore
    the following Trouble Report is no longer valid:

    We confirm instead the other problem:
    The NoMachine error log file is filled with messages ‘Cannot assign requested address’


    I did find the solution a couple of minut/and hours after starting the thread, I don’t remember what threat it was, but the solution came from the forum.

    But as you, Haven, mention for some reason the installation proceeded successfully even though there was a problem if the hosts file.
    Except I do not see any ERROR  in the nxinstall log.
    I can include the most recent nxinstall.log and a cut down version of the error logs because I fixed the issue rapidly after doing this install.

    Obviously I removed 110367 lines from error log plus the last regular logs lines since they include my ip and are just “info”, but I did not touch the nxinstall.log

    Hope this helps answer why my install proceeded without any warnings or errors (that I can see).
    You could try in leap, just edit the hosts file and see if you get the same results (successful install without errors).
    I made a typo previously the hosts file was set to: hostname
    instead of the regular localhost hostname


    Hello Gatos,
    Further logs weren’t requested because we did reproduce the problem on openSuse 15.1.
    The Trouble Report opened to handle this issue is: TR12R09942.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.