Cannot connect over the internet

Forum / NoMachine for Mac / Cannot connect over the internet

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #33835

    Hi Team,

    I am using the NoMachine version 6.6.8 and I am unable to connect to Ubuntu machine. Almost every time it is getting timed out and sometimes it gets connected. Previously it was working fine with the same NoMachine version and with the same Ubuntu machine. Even still I am able to connect it but only sometimes (1 out of 30-40 attempts).
    I am sending you the logs as zip file (.nx directory in compressed format) which have the current active session connected as well as multiple failed attempts.


    Almost every time it is getting timed out and sometimes it gets connected.

    Strange. That sometimes you can connect and sometimes you can’t can indicate a problem with the network and not with NoMachine.

    1) When trying to connect, if you are seeing “Error ‘Operation timed out'”, this indicates that NoMachine on the remote computer is not reachable.

    When this occurs you should verify the status of NoMachine server.

    You can do that from a terminal using an account with administrative privileges is needed:

    sudo /etc/NX/nxserver –status

    Output should be similar to:

    $ sudo /etc/NX/nxserver –status
    NX> 111 New connections to NoMachine server are enabled.
    NX> 162 Enabled service: nxserver.
    NX> 162 Enabled service: nxnode.
    NX> 162 Enabled service: nxd.

    2) However, then there is this in the logs “A connection timeout has occurred while trying to connect to ‘’ on port ‘4000’. The issue could either be caused by a networking problem, by a firewall or NAT blocking incoming traffic or by a wrong server address. Please verify your configuration and try again.'”

    NoMachine connections use by default NX protocol and port 4000. Port 4000 must be free so check that it is not being used by other applications maybe?

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.