Cannot connect over WAN

Forum / NoMachine for Raspberry Pi / Cannot connect over WAN

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #38032

    I have a Raspberry Pi 4 tethered to my phone for internet. NoMachine client will not connect to the Pi over the internet. The external IP (public IP) does not display in the server status. I have tried the following command with no success:

    sudo /usr/NX/bin/nxserver –upnpmap


    Local IP

    Gateway IP

    External IP

    Using the public IP provided by a search “what’s my ip” in the client side to connect also does not work.

    I’ve attempted many strategies in the knowledge base including port forwarding but nothing has worked. Connection seems to only be possible over LAN.

    Has anyone else had success connecting to a Pi over the internet through a mobile network?

    NoMachine version: Enterprise Desktop Evaluation 7.9.2

    Local machine: Windows 10

    Remote machine: Raspberry Pi 4



    port-forwarding is done on the router and you have to follow the instruction according to your router.

    Can you check that EnableUPnP in the server.cfg on the Raspberry is uncommented and set to NX (without #)?

    EnableUPnP NX

    Just so I know that you’ve check the right side, did you check the IP address of the Raspberry by going to the whatismyip website from the Raspberry?

    There was another user in a similar position and he used ngrok which avoids the port-forwarding. Take a look here:


    Hi, thank you for your response. Yes, I did edit server,cfg in /usr/NX/etc to EnableUPnP NX as you described. The external IP is still not being pulled. I had searched “whats my ip” on the Raspberry Pi to determine which address to connect to. I couldn’t connect with the Pi’s public IP address.

    I now own a static IP which I setup on the Pi using a configuration file from Windscribe. I’ve tried to setup port forwarding with the static IP from Windscribe’s server but this too has not been successful.

    The Pi is connected to the internet through my phone so there isn’t a physical router that I can connect to using the router’s address ( to setup port forwarding. Is there a way to setup port forwarding using a wireguard VPN configuration?


    Look at

    If you’ve tried with ngrok like in the other topic and it didn’t work, NoMachine Network will be useful to you when it is released (version 9) This will remove the need to know your computer’s IP address in order to connect and will also remove the need for port-forwarding on the router.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.