Cannot connect to one machine

Forum / NoMachine for Linux / Cannot connect to one machine

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #43001
    kdv666
    Participant

    Hello,

    I have a home network with 5 machines, all running Ubuntu linux 22.04.

    From the machine (sophie) I have on my desktop, I need to open windows to work on the other 4.

    Three of the four work fine, but one of them (kath) doesn’t. Trying to connect to it, the window opens and just sits there with the little window spinning.  If I reset the saved data for that machine, it asks me for username and password, then the same thing happens.

    I can’t for the life of me work it out.  The settings on kath’s instance of NX are the same as on the working machines.  I reinstalled nomachine, but had no relief.  I noted that my problem is similar to #42108, although not quite the same, so I tried applying the solution which worked there, but also no relief.

    The IP I feed to the setup is correct, I double checked.  And nxserver is listening on port 4000 on kath.

    Am I missing something obvious here?

    Thanks, Kenneth

     

    #43006
    Britgirl
    Participant

    Do they all have the latest version of NoMachine installed on them?

    What is the desktop environment on the problematic Ubuntu machine? Is Wayland or Xorg running as the display server?

    Can you try connecting from the problematic machine to one of the others?

    Can you paste the link to the topic where you found a potential solution but it didn’t work?

    #43007
    kdv666
    Participant

    Hi, and thanks for your reply.  It’s appreciated!

    Yes, 8.4.2 on all machines.  It’s the latest one on the website, and checking for updates says no newer verstions.

    The desktop is X, or to be more specific, Xorg.  FWIW, the running command is:

    /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

    I can connect from the problem machine (kath, 192.168.4.32) to others without problem, e.g. marie(192.168.4.35), but not vice-versa.

    The other thread was

    Can’t connect to the NoMachine server after moving to a new server

    As I said, the solution given there didn’t help me.

    And just to add something new since I originally posted:

    I reset the link to kath from my main machine.  When I tried connecting to kath again, it did the normal things including name/pw, but then it indicated it was asking permission on kath to complete the link.

    However: The question didn’t appear on kath.  It appeared on a different machine on my network, maggie (192.168.4.33).

    So weird!

     

    #43011
    Britgirl
    Participant

    The other thread was

    Can’t connect to the NoMachine server after moving to a new server

    It might not be the same problem as the one listed there, so first let’s try to understand better what the steps are to reproduce your specific problem.

    By “link” I assume you mean connection.

    it indicated it was asking permission on kath to complete the link….The question didn’t appear on kath. It appeared on a different machine on my network, maggie (192.168.4.33).

    Not sure what you mean here. Do you mean that you started a connection to machine kath, which needs to authorize the connection, but the question “do you want to authorize” appears on another machine? Maybe you just mixed up the connection files or used the wrong IP address/hostname to connect?

    Anyway, this is what we need:

    screenshots of the session to machine Kath being started right up until you see the spinning wheel and you are forced to interrupt it. Please remove any sensitive info from the images. Or you can submit a brief recording.

    Then, logs from the server machine Kath and also logs from your Player machine (the computer you are connecting from).
    To get logs please follow the instructions here:

    https://kb.nomachine.com/DT11R00182#2 for Linux. In short:

    1) On the server from a terminal sudo /etc/NX/nxserver --debug --enable all
    2) on the computer you are connecting from, tick the box ‘Don’t delete log files on exit’ option enabled in Settings -> Player -> Security. Otherwise the client logs will be missing or only partial.
    3) Start a connection to Kath and reproduce the problem
    4) On the server sudo /etc/NX/nxserver --debug --collect (they are stored in /usr/NX/var/log/archive)
    5) Zip up and send both sets of logs to forum[at]nomachine[dot]com

    If you want add the images I requested earlier as attachments to the same email, please do.

    Thanks

    #43014
    kdv666
    Participant

    Hello,

    Ok, just to be clear.  My desktop where I run the client, is sophia(192.168.4.41).  The problem machine is kath(192.168.4.32).

    I did a nxserver –logrotate first to keep the reports recent.

    I include the requested screenshots and logs.

    Please note that I left the machine hung at the second screenshot for about 2-3 minutes.  In that time, the nxserver.log file grew from 93 bytes to something over 13MiB.

    Regards

     

    #43022
    Britgirl
    Participant

    One set of logs (the ones from Kath?) did not attach. Please send it to forum[at]nomachine[dot]com

    #43026
    Britgirl
    Participant

    Also, the logs that you sent us, from Sophia which you say is the client, do not contain the logs I requested.

    2) on the computer you are connecting from, tick the box ‘Don’t delete log files on exit’ option enabled in Settings -> Player -> Security. Otherwise the client logs will be missing or only partial.

    #43027
    kdv666
    Participant

    Ahh, it exceeds the allowed size, it would seem.  I’ll see if I can split it up.

     

    #43028
    kdv666
    Participant

    That’s very odd.  I did tick that box.  I just opened up the settings, and it’s still sitting there ticked.  ???

    I’ll try again with the client sophia.

    I’ll leave it hung for a shorter time to see if it produces smaller log files, and try again with both sophia and kath

     

     

    #44056
    Britgirl
    Participant

    Server side logs show nothing strange (Kath) and the client side logs are still empty.

    On the machine Sophie, please open the Player, go to Player settings and tick the checkbox “Don’t delete log files…:” Then go back to the Machines tab in the Player on Sophie and start your connection to Kath. Do not close it, but keep the Player open. Then, create a compressed archive of the .nx directory (whilst the Player window is still open, you might be seeing the wheel spin like you described)

    sudo tar -cvp --exclude 'cache*' --exclude 'images' --exclude 'temp' -f - PATHTOUSERHOME/.nx | gzip -c nxdir.tar.gz

Viewing 10 posts - 1 through 10 (of 10 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.