Cannot connect to Ubuntu running on ARMv7

Forum / NoMachine for Linux / Cannot connect to Ubuntu running on ARMv7

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #14513


    I’m running Ubuntu 16.04.2 on an Odroid XU4. After installed NX 5.2.21 I was able to connect, but this was to the existing desktop session which after going headless was fixed at 1024×768 and couldn’t be changed. After some searching, I found this post: ubuntu-16-04-headless-resolution-stuck-1024×768.

    After following the instructions there and disabling lightdm, I now get the warning that there is no display running and do I want to create one. Replying “yes” and continuing then throws the following error: The session negotiation failed. Cannot create a new display. Digging around in the logs, I found this error:
    Apr 20 18:48:52 odroid gnome-session-binary[4602]: CRITICAL: We failed, but the fail whale is dead. Sorry....
    Searching on this, I came across this post: cant-create-a-new-virtual-desktop-on-ubuntu-14-04 which appears to describe the same problem.

    I followed the instructions from the Knowledge Base article, but I still get the “dead whale” message.

    Attached are the server side logs.



    Thanks for the report. We will take a closer look to this issue. It’s appears on specific distribution. Is that a Ubuntu Mate? It seems that the wrong command to create session is called.

    So for the workaround you should change DefaultDesktopCommand key in the node configuration key to “/usr/bin/mate-session” (in case you use Mate). So open mentioned file sudo vi /usr/NX/etc/node.cfg, then comment old DefaultDesktopCommand key by adding # sign on line beginning and create new line below with DefaultDesktopCommand "/usr/bin/mate-session". After restart nxserver (sudo /usr/NX/bin/nxserver --restart) you should be able to create session.


    Yep, changing the DefaultDesktopCommand worked. Plus I could back out the change I made for AR09L00814 and it still works.



Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.