Cannot copy and paste to and from remote PC

Forum / NoMachine for Windows / Cannot copy and paste to and from remote PC

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #25937

    I’m using Windows 10 Version 1909 for both computers. One is at a remote location from the other. I’m using the latest versions of your software 6.9.2_1. I first tried the Free Version and got this issue. So removed the Free Version from the remote PC and used the Enterprise and still cannot copy and paste between the two Windows 10 computers. When I browse to the CFG File they both are Player.cfg Files so neither has a Server.CFG for me to see why clipboard is missing or not working. Under Security Preferences I have all boxes unchecked. When I connect remotely I thought I would have to use an external IP address but instead it works with a local Private IP which is different from using RDP that I’m used to. I’m connecting to a Physical Display.

    Please advise.




    We are not aware of copy and paste problems between Windows computers. Please provide specific steps to reproduce e.g.

    – start NoMachine session to remote computer

    – open application on remote computer (which application?)

    – from local Windows computer copy some text from the application (which application?)

    – move to NoMachine to paste the copied text

    Regarding your comment about connecting remotely, I’m not sure what you mean. If the two computers are on the same local network, the other remote computer of the two will show up in the Recent Connections panel. So you can just click the computer icon to connect. See here:

    If they are not on the same network, you will need to use the public-facing IP address of the remote computer.

    Did you follow the instructions here?

    For LAN access

    For access over the Internet



    Today I got the the session negotiation failed.

    When I first installed it and it was working, I would right click on one PC and copy the file. Then I would go to the other PC and choose to paste the file and nothing happens. I could only use the File Transfer method to move a file from one PC to the other from the Desktop. The Computers are at different site locations. When I use RDP I normally use an external IP address like and it connects to the remote PC and everything works. On the Cisco firewall at the remote location:

    I set up and access rule that has its destination set as my actual local IP on the Remote PC I name the Service TCP-3389 and save that access rule.

    I then set up a Nat rule that again uses my actual local internal IP address from the site remote PC. I then set that up with an automatic Translation Rule that points to a translated IP address like which is used above to connect to the remote PC with the include port number. Under Advanced setting here I set the Service Protocol to TCP to forward the real port 3389 to port 3391. This is called the source Inside and destination outside. The other part of that has the same info on the Object is called the Outside Source and Inside destination.

    The last piece needed to get the RDP to work with the remote on site PC is the created Network Object/Groups.This has the same static local IP address as seen above172.16.44.105 which is the actual local IP address of that remote PC. It also has that same translated IP address as seen above Under advanced in that location it has the inside source and outside destination with TCP real port 3389 to mapped port 3391. With that, the RDP works flawlessly.

    When I try and use your software, I installed the software first on the remote off site PC. When I start the software up it only finds the following:NX:// and a ssh:// with no port info which is the actual local internal IP address of the Remote PC which again is at a different location then the PC I’m setting this up on trying to connect to it remotely.

    I then installed your software on my local workstation and it finds the following: NX://192.168.x.xx which is my actual local IP address. So I go through the settings with your software and it surprisingly connect to the remote off site PC using my local IP 192.168.1.xx using the given 4000 port. This worked until the next day and then I started getting the session negotiation failed today. When it was working yesterday it just couldn’t perform a simple copy from the Local Desktop to the Remote Desktop or vice versa.

    Like I mentioned before, when I browse to C:\Users\Tom nx/config on either the local or remote PC I only saw a Player.cfg on both the local and remote PC, no server.cfg to look for clues on the copy and paste issue. This evening I just checked on my Local PC and found a server.cfg on it but I thought this was suppose to be the Player non Server PC. When I checked the remote PC at the other location, I still only found a Player.cfg but I thought that PC was suppose to be the server.

    If I use Whats my IP on my local PC, I get an Public ID address like: xxx which is provided by my ISP Comcast.

    On the remote PC I get using Whats my IP the Public address is like: from that ISP

    I’m not sure what to try next or just give up on using your software.

    Please advise.


    Thanks for the detailed explanation. If you’ve installed  free version of NoMachine on both your computers, each one will have a player.cfg and server.cfg. You don’t need to edit these, NoMachine works out of the box in the majority of scenarios. If you are connecting to the remote computer when you are on the same local network use this IP NX://192.168.x.xx, if you are connecting to it and you are not on the same network use this or if it’s the other PC you need to connect to it will be xxx.

    See the article about computers behind NAT if you didn’t already do so.

    How to connect to NoMachine when the server is behind a NAT router or a firewall

    For drag and drop, you cannot drag and drop folders, you will have to zip them and then drag and drop. Is this what you are trying to do? For drag and drop read here:

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.