"Cannot create a new display, please contact your system administrator"

Forum / NoMachine for Linux / "Cannot create a new display, please contact your system administrator"

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #15940

    I recently updated my NoMachine server and client from 3.5 to 5.3.12 and I’ve run into this error. I’ve looked at the previous topic and TR (https://www.nomachine.com/TR02O07604) and followed that advice. I’ve tried pretty much every combination of settings with those 3 keys (commented and uncommented) and the client either succeeds in logging in, but can’t access any display or make a new one, or it fails at logging in and gives the aforementioned error. Has anything changed since 5.3.9? What should I do if the TR doesn’t help?

    Thanks in advance.


    What OS or distribution and version are you connecting from and to?


    I’m connecting from Windows 7, to Ubuntu 14.04.5 LTS.



    I think I’m having the same issue.


    What is your desktop environment? Possible that you have unrecognized by system command in the node configuration file in the DefaultDesktopCommand key. Did you change it before update? Please paste here output of the command sudo grep DefaultDesktopCommand /usr/NX/etc/node.cfg.

    If this is the case you need to edit /usr/NX/etc/node.cfg file find and change DefaultDesktopCommand to correct one. On Ubuntu 14.04 with Unity it should be:

    DefaultDesktopCommand "/etc/X11/Xsession 'gnome-session --session=ubuntu'"


    Okay, so I added the line you suggested into node.cfg and restarted the server, and the client seemed to make more progress. However, as I was going through some graphical options for setup, the connection failed with “Error 134: Protocol error.”

    I changed the settings in node.cfg back to default (DefaultDesktopCommand “/etc/X11/xinit/Xsession default”) and tried again, and got a different error, which is the same as before “Cannot create a new display, please contact your system administrator”. Now it seems like however I try to reproduce error 134, I can’t get back to it. I thought I was getting closer, but I’m back where I was.

    On the server side, when I restart the server after making changes to node.cfg, I am getting these messages:

    sudo /usr/NX/bin/nxserver –restart

    NX> 162 Disabled service: nxserver.

    NX> 162 Disabled service: nxnode.

    NX> 162 Disabled service: nxd.

    NX> 161 Enabled service: nxserver.

    NX> 162 WARNING: Cannot find X servers running on this machine.

    NX> 162 WARNING: A new virtual display will be created on demand.

    NX> 161 Enabled service: nxd.

    The server is headless, perhaps I should add.


    Are you sure the formatting you inputted was correct? See my previous reply from October 5th, I edited it to show the exact code properly formatted.

    Please write what desktop environment have you installed on this machine?


    ls -l /usr/share/xsessions/

    total 20

    -rw-r–r– 1 root root 222 Feb 24  2014 fluxbox.desktop

    -rw-r–r– 1 root root 231 Mar 12  2014 gnome-classic.desktop

    -rw-r–r– 1 root root 216 Mar 26  2015 gnome.desktop

    -rw-r–r– 1 root root 272 Sep 30  2014 gnome-fallback-compiz.desktop

    -rw-r–r– 1 root root 310 Sep 30  2014 gnome-fallback.desktop


    I recopied the text you included, too, and no, that didn’t change anything either.



    We couldn’t reproduce this problem in our labs – before you check workaround which is written below – can you send logs that we could investigate problem? To do that just pack as root /usr/NX/var/log directory and send it forum[at]nomachine[dot]com. Is it a clean NoMachine installation or there were some configurations before you have installed our program (previous installation?)  Is it Ubuntu 14.04 installed without any desktop environment and then you have installed gnome and fluxbox? Can you indicate which command you used to install it?

    First search for command starting session: which gnome-session. Output should be similar to:


    Now check available gnome sessions. Output should be similar to:


    Check location of your Xsession scripts. If script are in two places use path to Xsession from top of list:


    Now you can edit DefaultDesktopCommand key in the node configuration file (/usr/NX/etc/node.cfg) and change value to available session. For example, for gnome-classic:
    DefaultDesktopCommand "/etc/X11/Xsession 'gnome-session --session=gnome-classic'"
    for gnome3d:
    DefaultDesktopCommand "/etc/X11/Xsession 'gnome-session --session=gnome'"


    That didn’t work either. I’m sending the logs, but I’ll add the comments here, too.
    This version was installed over NoMachine 3.5, which I was also having trouble getting to work (though I did use NX extensively a few years ago on this server). Ubuntu was originally installed without a DE (if I remember right, it was a long time ago), and I installed gnome while one of the other server’s users installed fluxbox, I think. I use apt-get for installation.

    Thanks for all your help!


    It looks that it could be some system’s session initiation script problem. Can you paste here output of commands:

    ls -lt $(whereis gnome-session)
    ls -lt /etc/X11/Xsession
    ls -lt /etc/gdm/Xsession
    ls -lt /etc/X11/xinit/Xsession

    Did you try to set: DefaultDesktopCommand "/etc/X11/xinit/Xsession 'gnome-session --session=gnome'"?

    As workaround you could try to set key with one of four following commands (of course if they exists in the system): gnome-session /usr/bin/gnome-session /bin/gnome-session /usr/local/bin/gnome-session.

    For example: DefaultDesktopCommand "gnome-session".



    ls -lt $(whereis gnome-session)
    ls: cannot access gnome-session:: No such file or directory
    -rwxr-xr-x 1 root root 235904 Mar 26  2015 /usr/bin/gnome-session
    -rwxr-xr-x 1 root root 235904 Mar 26  2015 /usr/bin/X11/gnome-session
    -rw-r–r– 1 root root   1515 Mar 26  2015 /usr/share/man/man1/gnome-session.1.gz

    total 48
    -rwxr-xr-x 1 root root 10504 Mar 26  2015 gnome-session-check-accelerated
    -rwxr-xr-x 1 root root 14768 Mar 26  2015 gnome-session-check-accelerated-helper
    -rwxr-xr-x 1 root root 19032 Mar 26  2015 gnome-session-failed

    total 28
    drwxr-xr-x 2 root root  4096 Oct 10 09:50 sessions
    -rw-r–r– 1 root root  2504 Mar 26  2015 gsm-inhibit-dialog.ui
    -rw-r–r– 1 root root   692 Mar 26  2015 hardware-compatibility
    -rw-r–r– 1 root root 13073 Mar 26  2015 session-properties.ui
    ls -lt /etc/X11/Xsession
    -rwxr-xr-x 1 root root 3730 Jun 24 2008 /etc/X11/Xsession

    ls -lt /etc/gdm/Xsession
    -rwxr-xr-x 1 root root 6680 Apr 3 2015 /etc/gdm/Xsession

    ls -lt /etc/X11/xinit/Xsession
    ls: cannot access /etc/X11/xinit/Xsession: No such file or directory

    The server doesn’t seem to have /etc/X11/xinit/Xsession, so I tried that key in node.cfg but it didn’t work.

    I tried all of the options you listed at the end, too. They all resulted in a failure to create a new display, and when I restarted the server I got the “NX> 162 WARNING”s, too. I only tried gnome-session and /user/bin/gnome-session. The other two don’t exist.


    Command: DefaultDesktopCommand "/etc/X11/Xsession 'gnome-session --session=gnome'" should work in that case.

    In logs we can see:

    nxserver.log:2017-10-10 00:12:53 400.683 24723 NXNODE   ERROR! Cannot write to .Xauthority file in /home/diapadion on the local host. Please verify permission attributes for that file.

    Can you check permissions of /home/diapadion/.Xauthority file? It should be set to 0600 and user diapadion should be the owner. If not – you need to change permission or eventually – remove the file.


    Yes, that worked! Thanks a heap for helping me figure this out.



Viewing 14 posts - 1 through 14 (of 14 total)

This topic was marked as solved, you can't post.