Cannot create the home directory for the nx user

Forum / NoMachine for Windows / Cannot create the home directory for the nx user

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #11596

    Giving NoMachine free 5.1.26 a try after using VNC for a long time.

    One Windows 10 x64 machine installs fine, seems to work well (I’ll call it PC1)

    Another Windows 10 x86 machine (I’ll call it PC2) errors on install every time:

    Cannot create the home directory for the nx user

    After rebooting this PC2, I can connect from PC1 with a username and password etc but unable to start a desktop, even through the PC2 service says it is still running.  On the PC1 client I get:

    The server was unable to make the local display available or access to the local display is disabled.

    I’m going to give it a second chance but the fact the back end is not natively coded for Windows give me doubts to its reliability for the Windows platform.  Other forum posts mostly refer to v4 or are unsolved by the thread or refer to Linux so have been of no help in this instance.

    Thanks for any advice!


    Hello Hugga,

    Do you use on your PCs Active Directory or similar technology?
    Is ‘nx’ a domain user?

    Could you zip whole log dir on both machines (PC1,PC2):


    and sent to forum[at]nomachine[dot]com, please.


    Hi Zag

    Problem solved.

    The issue was to do with a corrupt Windows C:\Users\Default profile, not a NoMachine issue.

    I thought maybe something was wrong with my own profile being corrupt, so I created a new Administrative account with the intention of installing NoMachine from there.  But I had issues logging on to the new account and a new profile could not be created (ie from the Default profile).

    Naturally this is the cause of the error “Cannot create the home directory for the nx user”.  Since there is no profile there can’t be a home, although in UNIX this would be there can’t be a profile because there is no home directory. 😉  The error message is a little misleading for a Windows world but makes sense in a UNIX world.  Not unsolvable though!

    I copied a Default folder from a clean install and reapplied inherited permissions to solve the issue with Windows.

    Thanks for the offer of help.  Reinstalled NoMachine and all working no errors.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.