Cannot create virtual desktops on Centos 7

Forum / NoMachine Cloud Server Products / Cannot create virtual desktops on Centos 7

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #6640


    I’m currently evaluating NX4 Workstation edition (4.4.12) on a Centos 7 VM. I use the enterprise client (same version) on Windows 7 to connect.

    Connecting to the physical desktop works as desired. Because of the restricted screen resolutions I’d like to use the virtual desktop feature (that’s the reason I use the workstation edition instead of the free one).

    The problem is, when I start a new virtual desktop session, the client shows the spinner and “Creating a new virtual desktop” virtually forever. nxserver.log shows a timeout on session creation, nxerror.log shows an error 97 “Address family not supported by protocol”.

    In node.cfg I set the DefaultDesktopCommand to “/etc/gdm/Xsession default”. Also tried gnome-session instead of default and also the default “gnome-session -session=gnome”.

    Can you please advise me how to fix it, physical desktop is no option for us.





    Just for further information, I also tried xfce4 instead of gnome, same result


    We couldn’t reproduce problem on basic configured CentOS 7. Anyway the description can indicate that it may be problem similar to

    Is there possibility that your user belongs to a group with a name containing spaces?

    If not – please run debug mode and send logs from server side if you were able to reproduce problem. There is instruction how to collect logs:

    Please send everything to forum[at]nomachine[dot]com.



    thanks for the hint. The user in question does not belong to any groups with whitespaces, only dashes. However, user management and authentication is done via LDAP using ipaserver.

    I send you an email containing the logs.




    Thank you for reporting this issue. We reproduced the problem and opened the following trouble report:

    This issue should be solved in the next update, you may check the ‘Notify me when the TR is closed’ option in the trouble report page to be informed when the fix is released.



    I have the same issue.

    System: Ubuntu 14.04 LTS 64bit with XFCE
    NoMachine Enterprise trial: 4.4.12

    I can’t turn on virtual desktops.

    root@nx-srv:~# /usr/NX/bin/nxserver  –ruleadd –class session –type unix-xsession-default –value yes –user milosz
    NX> 553 Profiles are not permitted on this server.
    NX> 500 ERROR: Cannot add rule for user: milosz.

    root@nx-srv:~# /usr/NX/bin/nxserver –ruleadd –class feature –type enable-profiles –value yes –system
    NX> 553 Profiles are not permitted on this server.
    NX> 500 ERROR: Cannot add rule for user: NX system.

    root@nx-srv:~# /usr/NX/bin/nxserver  –resourcelist –class feature
    NX> 104 Resource list:

    Class     Type                       Value
    ——— ————————– ——
    feature    manual-node-selection      yes
    feature    server-clipboard           yes
    feature    enable-profiles            no
    feature    enable-guest               yes
    feature    enable-multinode           yes
    feature    client-clipboard           yes
    feature    bandwidth                  no

    I have installed client on my notebook nomachine_4.5.0_1_x86_64.rpm (Fedora 21) and for Windows 7. After connect on the list is only Physical Desktop.


    Hello milosz,
    Please make sure that your server has Enterprise version installed by
    /usr/NX/bin/nxserver --version

    The described behavior is consistent with NoMachine (free version) where profiles and virtual desktops
    are not supported.

    If you want to get access to virtual desktops please remove current
    NoMachine software from the server. Also remove /usr/NX directory,
    especially make sure that files:


    are deleted before installing: NoMachine Enterprise Server (or one
    of the other products offering the same functionality)

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.