Cannot detect any display running

Forum / NoMachine for Linux / Cannot detect any display running

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
  • #26063

    Dear all,

    I think this is a recurrent issue, but after trying some staff read in this forums I decided to do a post. I have restarted the nxserver and disabled wayland but the issue does not disappear.

    In attached you can find the connection log. Any more information you need I will provide.

    Thanks in advance.


    What OS and version is on the client? What Linux is it on the server side?

    The logs didn’t attach. I would send both client side and server side to forum[at]nomachine[dot]com.


    Hi Britgirl,

    OS version in local is Ubuntu 17.10, client is NoMachine 6.9.2.

    Server side is an Amazon AMI, OpenSUSE Leap 42.1 x86-64

    Here are the logs:


    “NX> 164 Connection policy:

    Type                       Value
    ———————–    ——
    autocreate                  yes  
    autoconnect                 yes  
    automigrate                 yes  
    desktop                     no   
    dialog                      no   
    NX> 105 Resourcelist
    NX> 104 Lista de recursos :

    Class     Type                       Value
    ——— ————————– ——
    session   nxvfb                       no
    session   unix-console                no
    session   unix-gnome                  no
    session   vms                         no
    session   unix-remote-custom          no
    session   unix-xsession-default       no
    session   vnc                         no
    session   windows                     no
    session   unix-desktop                no
    session   unix-remote                 no
    session   unix-cde                    no
    session   shadow                      no
    session   unix-kde                    no
    session   unix-application            no
    session   unix-default                no
    session   unix-xdm                    no
    session   physical-desktop            no
    session   unix-script                 no
    service   server-printer-sharing      yes
    service   client-network-sharing      yes
    service   audio                       yes
    service   server-network-sharing      yes
    service   client-usb-sharing          yes
    service   server-disk-sharing         yes
    service   local-recording             yes
    service   client-smartcard-sharing    yes
    service   client-disk-sharing         yes
    service   client-printer-sharing      yes
    service   microphone                  yes
    service   server-file-transfer        yes
    service   client-file-transfer        yes
    service   session-recording           yes
    service   server-usb-sharing          yes
    feature   enable-multinode            no
    feature   client-clipboard            yes
    feature   manual-node-selection       yes
    feature   server-clipboard            yes
    feature   node-load-balancing         yes
    feature   bandwidth                   no
    node      localhost:4000              yes
    node      virtual-desktops-limit      no
    node      connections-limit           no
    NX> 105 Listsession –user=”cfd” –status=”disconnected\054connected” –geometry=”1920x1080x24+render” –type=”all” –reconnectable=”yes”
    NX> 149 Confirmation required for creating new frame buffer on server
    Startxserver –option=”yes”
    NX> 500 ERROR: No se puede crear una nueva pantalla. Por favor, contacte su administrador sistema.
    NX> 127 Session list of user ‘cfd’:

    Display Type Session ID Services Depth Screensize Status Session name Username Platform Users Crea Node
    ——- —- ———- ——– —– ———- —— ———— ——– ——– —– —- —-

    NX> 148 Server capacity: not reached for user: cfd
    NX> 105″


    “Info: Starting NoMachine version 6.9.2.
    Info: Loading settings from ‘.nx/config/player.cfg’.
    Info: Loaded translation files for ‘Spanish’.
    8529 8529 20:20:55 085,952 Main: Creating the client session.
    8529 8529 20:20:55 086,044 ClientSession: Initializing session at 0x136f8f0.
    8529 8529 20:20:55 238,862 ClientSession: Initialized session at 0x136f8f0.
    8529 8529 20:20:55 239,175 Main: Entering the GUI event loop.
    Info: Slave server running with pid 8555.
    Info: Listening to slave connections on port 37550.
    8529 8529 20:21:04 178,539 ClientSession: Starting session at 0x136f8f0.
    8529 8529 20:21:04 179,306 ClientSession: Going to start session ‘/home/ordenador/Documentos/NoMachine/Conexión a’.
    8529 8529 20:21:04 192,663 Connection: Initializing connection at 0x167dd10.
    8529 8529 20:21:04 192,863 Connection: Initialized connection at 0x167dd10.
    8529 8529 20:21:04 192,888 Connection: Starting connection at 0x167dd10.
    8529 8529 20:21:04 192,903 ClientDaemonConnector: Starting a new connection to host ‘’ on port ‘4000’.
    8529 8529 20:21:04 193,019 Connection: Started connection at 0x167dd10.
    8529 8529 20:21:04 198,808 ClientSession: Started session at 0x136f8f0.
    Info: Connection to port 4000 started at 20:21:04 418,577.
    8529 8565 20:21:05 279,846 ClientSession: A valid certificate for this server was found.
    8529 8565 20:21:07 286,411 Connection: WARNING! Skipping a duplicate code 1000.
    8529 8529 20:21:07 501,816 ClientSession: Going to query the server for available services.
    8529 8529 20:21:09 533,254 Connection: Connection at 0x167dd10 failed.
    8529 8529 20:21:09 533,287 ClientSession: Runnable at 0x167dd10 caused the session at 0x136f8f0 to fail.
    8529 8529 20:21:09 533,300 ClientSession: Failing reason is ‘La negociación de la sesión falló.

    Error: No se puede crear una nueva pantalla’.
    8529 8529 20:21:09 540,614 ClientSession: Stopping session at 0x136f8f0.”



    Many thanks.



    As this is Amazon virtual machine it is probably headless from the start, so there might be a few issues associated with this.

    Did you had to install Xserver and graphic environment manually or it came with it?
    If you did install it afterwards, are you sure it is running? If yes – here is the problem, that NoMachine did not recognize it.

    If no, the NoMachine will try to run the virtual session instead, but it need to be supplied with proper application path as to what to run.

    Please check the node.cfg file for key DefaultDesktopCommand and see what is there, and make sure it points to the desktop environment
    you installed. If it points to the generic Xsession script it may not be enough for operating system to run it.

    If there is a physical session running and we did not recognize it, we will require the server logs for debugging. Please also note that very rarely after
    installing the desktop environment the operating system requires restarting of NoMachine to be able to properly recognize the desktop.

    Article on how to collect logs: (“How to gather debug logs for support requests”)

    Please enable the debug and then do

    /etc/NX/nxserver --restart

    You can use the command

    /etc/NX/nxserver --debug --collect

    after the restart for NoMachine to automatically collect and pack the logs.

    Please send the logs to forum[at]nomachine[dot]com using the title of that forum’s thread as the mail’s subject.



    Thank you for answering,

    I have to say that I have been working with the same Amazon AMI, with the same instance and configuration and with NoMachine since January and everything has worked properly. This happens to me only since a few days. So maybe is related with some update, but the only one I remember is related with the internet connection device.

    NX server came with it, I didn’t install it later.

    In DefaultDesktopCommand I can see: “dbus-launch –exit-with-session gnome-session –session=ubuntu”


    Please, I need an answer.



    If it worked before the update- something may have changed in the system that we were not able to handle. And the most probable thing here is the
    update to gnome.

    My question remains though. Do you run a headless physical session or make NoMachine to run desktop on virtual session.

    If its the later, you probably need to update the DefaultDesktopCommand to what is right now used by the gnome.

    If you run:

    grep ^Exec /usr/share/xsessions/*.desktop

    command You will get how the system is running installed desktop environments.

    If you are running headless physical session, we need logs to check why it is not detected.



    Good afternoon,

    That’s what I get when executing the command you said:

    “/usr/share/xsessions/ubuntu.desktop:Exec=env GNOME_SHELL_SESSION_MODE=ubuntu  gnome-session –session=ubuntu

    /usr/share/xsessions/ubuntu-xorg.desktop:Exec=env GNOME_SHELL_SESSION_MODE=ubuntu  gnome-session –session=ubuntu



    So that’s what I found.


    Any suggestion?


    Dear Mth,

    I hope that health is on your side, and I also wish you a happy Easter.

    I would like to have a solution for this. Last day I could work with NoMachine properly I finished with a simulation and since then I’m not able to see the results… I have done the work but I have no acces to it.

    I don’t understand where is the issue, because you only refer to one configuration but I imagine that there are two configurations, one from my local machine and other from AWS server, so please, refer always the side you are talking about. The AWS image is not mine, is public, so an error there would be rare.

    I don’t know what is a “headless phisical session” or a “virtual session”. Since the initials I opened my AWS console, activated my preconfigured server, open up a terminal and connect to it by ssh command. Finally open a NoMachine connection to view the server desktop. Very simple.

    At least, I would appreciate to know how all the related configuration should be, and I’m going to make my best in order to find and change it.


    Many thanks.



    On the openSUSE instance what is the GUI Desktop Environment (DE) installed?

    That output which you paste was from Ubuntu (March 31st). We need the server-side output.

    To check what DE it is on the OpenSuse instance on the server side, you need to connect there via ssh and execute command: grep ^Exec /usr/share/xsessions/*.desktop.

    If there is no installed GUI, you need to install one. For example with command:

    sudo zypper in -t pattern x11 gnome_basic



    Dear Mr. Kroy,

    This is what I get:


    So I think it has already installed xfce environment. What do you think?


    Yes, it’s XFCE. Please check DefaultDesktopCommand in the /usr/NX/etc/node.cfg (still on server side). It should be set similar:

    DefaultDesktopCommand /usr/bin/startxfce4

    If there is other value please modify it. Then it should start to work.


    So, what do you think?


    @Kalabagh, please look at Kroy’s previous response and check that it is set to what he proposed.

Viewing 15 posts - 1 through 15 (of 23 total)

This topic was marked as solved, you can't post.