Cannot detect any display running

Forum / NoMachine for Linux / Cannot detect any display running


Viewing 10 posts - 31 through 40 (of 40 total)
  • Author
  • #30674


    Yes the facts are pointing to the nxserver –daemon process that is responsible for physical session detection is somehow broken at machine startup.

    There are no differences in how we check the running sessions, so the only thing that is different should be the context the nxserver –daemon is started with.

    There is a faint possibility that during the Arch update and rollback that you mentioned the NoMachine service file was corrupted, did you perhaps try to reinstall NoMachine afterwards?

    In any case we probably will need to investigate this further, could you provide more information about the OS setup that may be relevant? E.g. was there any custom pam.d modifications made? Is there any antivirus software running or any centralized user database like Active Directory configured? Or any unconventional services running on startup?



    Yes, one of the first things I tried was reinstalling NoMachine, I did it multiple times with no luck.

    pam.d as far as I know has never been touched at all on this machine. There is a firewall running,  however this shouldn’t affect things. With the nvidia graphics card, everything should be running on X, I have also manually configured GDM to ensure it does so. Other than that, it’s quite a new installation, so there isn’t much going on. There’s something that’s causing it to start-up differently when it’s started automatically, but I can’t figure out what that is, I’ve spent a lot of time trying to configure different things in systemd, can’t seem to find anything …

    Are there any specific things I should be looking out for? There shouldn’t be much unconventional going on.


    I might try manually installing the package.


    I have attempted again to reinstall, and change some settings with systemctl, with no luck unfortunately :c


    sorry, with systemctl I meant systemD


    Anything else that I could try?


    Oh boy do I have a solution Hahaha sorry I’m so excited

    So it turns out that Mth is right in that thinking that the order of services aren’t starting up correctly. Before when I tried to delay the service, I used /bin/sleep, turns out this is not the correct way to do it, it works for some things but not in this case. Instead, I created a systemD timer service, and with some trial and error, set the delay to be 15 milliseconds after the graphical interface starts, like this

    -Disable nxserver.service
    -Create the file /usr/lib/systemd/system/nxserver.timer

    Description=NoMachine Server daemon

    and enable that. I’ve tested it 3 times in a row and it’s worked great 🙂

    For some reason that’s been causing problems, most likely due to other services starting at different times ¯\_(ツ)_/¯. I’m glad that I’ve found something that works, and I thank the eagerness of everyone trying to help 🙂


    Hi Loulou,

    Thank you for letting us know, we are glad you’ve found a workaround that works!

    Best Wishes 🙂



    So, it looks like I’m back again, somehow

    There was a new update for NoMachine in the package manager, so I updated to it, and…

    Cannot detect any display running 🤦‍♀️

    I checked all the services, they’re setup the same. However, now when I open the server settings application for NoMachine, then it can detect the display running. I’ve also noticed this checkbox “Share the desktop at server startup”, which no matter how many times I check, becomes unchecked as soon as I restart.

    I’ll be testing for now


    Actually, I reinstalled nomachine, removing everything and restarting, and now it works. Sorry, was getting worried 😂😅

Viewing 10 posts - 31 through 40 (of 40 total)

This topic was marked as solved, you can't post.