Cannot detect display running

Forum / NoMachine for Linux / Cannot detect display running

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #29829

    Hello, I am having issues with NoMachine on Arch. This is a freshly updated system and a brand new install of NoMachine 6.12.3

    OS Arch
    DE Gnome-shell 3.38
    DM GDM 3.38
    Wayland 1.18

    NoMachine 6.12.3

    When I try to log into my server from either a Linux client (also on arch) for from android the error is “Cannot detect any display running” selecting create a new one give “Cannot create a new display”

    Thanks in advance for looking into this



    Additional information:  This seems to be an issue with Wayland.  If I switch to XOrg nomachine works as expected, but if I am running Wayland NoMachine is unable to find a running display.  Hopefully a workaround which will allow me to switch back to Wayland will be found.  If I can provide any additional logs or help troubleshoot this please let me know.


    It looks it’s the same problem mentioned on that post:

    Please try workaround from @shiba

    Modify /etc/pam.d/nx to:

    auth       include       system-login
    account    include       system-login
    password   include       system-login
    session    include       system-login

    and change DefaultDesktopCommand value in /usr/NX/etc/node.cfg:

    DefaultDesktopCommand "/etc/gdm/Xsession 'env XDG_SESSION_TYPE=x11 DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/$(id -u)/bus gnome-session'"


    Thank you for the reply. The workaround you provided kind of helps. So now when I try to connect to the sever I still get an error saying:

    Cannnot detect any display running, Do you want NoMachine to creat a new display and proceed to connect to the desktop?

    Selecting yes creates a new XOrg session. I still can not connect to the running Wayland display nor connect to the existing Wayland session. Also I must logout of the NoMachine session to log back into the server locally.

    At this time running XOrg seems like a better workaround, Hopefully a solution that allows connecting the WayLAnd display can be found.


    Additional information:  Also note that if the user is already logged in NoMachine still creates a new session, but I just get a blank screen. I’m assuming that is because this is the free version which does not support multiple sessions? As stated before If Wayland is turned on NoMachine can not find a display. Disabling Wayland allows it to find and connect to the running display.


    Any thing else I can try?


    Did you tried to set also DisplayServerExtraOptions "-wlmode compositor" in the /usr/NX/etc/node.cfg? We didn’t have problems with desktop detection when Wayland is enabled. Did you use custom wayland configuration or enable some extensions? Can you try with default settings.


    thank you for the reply.  NoMachine still not con not detect my wayland display. I do not have any wayland extensions it is just the standard install. I also completely removed NoMachine and reinstalled (mainly to make sure I had not done something goofy to the config files that I didn’t remember).

    With both the out-of-the-box install and with the DisplayServerExtraOptions set to “-wlmode composter” NoMachine can not detect my display, nor can it create a new wayland display.

    Trying to create a new server shows the attached error.

    OS Arche
    DM gmd 3.38.1
    DE gnome-shell 3.38.1
    composter mutter 3.38.1
    display server wayland 1.18.0


    We’ve managed to reproduce it and opened a Trouble Report. Please sign up to receive notification of the fix at the following link:

    NoMachine server cannot detect Wayland local display on Arch Linux



    I can confirm I’m getting the same issue with Fedora 33 (RC, the final version is slated on Tuesday).

    Fedora 33 RC with NoMachine (free) 6.12.3, connection to a physical machine


    Here’s the output when I try to sudo /usr/NX/bin/nxserver --restart:

    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.

    That’s great to hear! I’ll follow the TR


    Wanted to provide an update to this topic.  It seems that NoMachine is again running under with Wayland gnome on Arch. Since there has not been a NoMachine update I’m assuming that it was some form of gnome regression that caused the issue. To verify I did a complete fresh install of NoMachine removing all my old configurations and it worked out of the box. My current configuration is as follows:

    NoMachine: 6.12.3
    DM gdm: 3.38.2
    DE gnome-shell: 3.38.2
    composter  mutter: 3.38.2


    Interesting observation. Setting GDK_BACKEND=wayland in /etc/environments prevents NoMachine from starting properly.


    Hello, since the most recent version is now 7.0.211, I suggest you update to this (which also fixes the TR which is linked above) and if there is any unusual behaviour, let us know by opening a new topic. Thanks! 🙂


    Thank you if I see anything unusual with 7.0.211 I will open a new topic.

Viewing 15 posts - 1 through 15 (of 15 total)

This topic was marked as solved, you can't post.