Cannot find the default enviroment when running without a GPU or display-manager

Forum / NoMachine for Linux / Cannot find the default enviroment when running without a GPU or display-manager

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #38841

    Hello guys, I am running my NoMachine setup on an Ubuntu Desktop 22.04 LTS host and the latest version of NoMachine. When the host is running with a GPU and a monitor plugged in the connection runs smoothly from any device (Mac, iPhone, Windows…).

    However, I need to run this PC as a headless server (as a kind of NAS) without a GPU on it (I need it for another device) and I need to be able to connect to it on a regular basis. However, when I tried to run the host without a GPU I get the following error displayed on a black screen: “Cannot find default environment. Please contact your system administrator”. I tried installing the GPU back into my pc and within my PC/Host (locally) I tried to stop the display-manager, reboot the NX server and connect again (with the GPU still on the PC), as mentioned on this article, but I am still getting the same error.


    Hi, as you probably read in the article you referenced, NoMachine is able to detect when the X server is not running and run its own virtual display, which is an embedded X server. If you don’t have an integrated graphics card or VGA port, NoMachine cannot detect an X server and thus launches its own “virtual desktop”. If there is a GPU, and so a physical X session is already running, NoMachine doesn’t need to run its own display to launch the desktop environment.

    That said, Ubuntu 22.04 doesn’t make available by default the command used by NoMachine to launch the desktop inside our virtual display. We will be making the necessary adjustments in an upcoming software update. In the meantime, please check one of these methods and let us know if it helps:

    I) install dbus-x11 package:

    sudo apt install dbus-x11

    II) set /usr/NX/etc/node.cfg key?

    DefaultDesktopCommand “dbus-run-session gnome-session --session=ubuntu”


    Hello, I have tried both alternatives and they wont work. Do you know of any other option to run headless? If there is no other alternative what would you recommend me to do in order to access a headless server (NAS) remotely?


    Hi, logs would be useful to be able to help further. Can you send us the logs from the server side? Please follow the instructions here and send them to forum[at]nomachine[dot]com.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.