Cannot grab special keys after upgrading to Ubuntu 20.04

Forum / NoMachine for Linux / Cannot grab special keys after upgrading to Ubuntu 20.04

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #31998

    Hello everyone,

    After upgrade from Ubuntu 18.04 to Ubuntu 20.04 with dist upgrade command I’ve been having issues passing special keys to my remote desktop, which runs on Ubuntu 18.04. For example pressing super key launches gnome startup menu on client (local) rather on host. Pressing alt+tab rotates running applications on client. Before upgrading grabing keyboard input worked fine (after ticking checkbox ‘grab keyboard input’).

    I also connect to the same remote desktop using a win10 pc and special keys are passing through.

    I’ve been using NoMachine for almost 2 years and I never had an issue passing special keys to remote desktop. Could it be some config that reseted after the upgrade? Or is it something more serious?


    Hi. Please try to start the player with the --activegrab option, by running the command

    /usr/NX/bin/nxplayer --activegrab

    If it helps you can either create a link to the player to always add that option, or you can edit the file $HOME/.nx/config/player.cfg and set the configuration key “Enable active keyboard grabbing” to “true”.


    Hi there,

    I have already tried using the --activegrab argument but it didn’t help.

    Is there anything else I could try?


    Hi, we have a Trouble Report currently open for Wayland:

    Grabbing the keyboard doesn’t work when Wayland is enabled


    Can you check that Wayland is disabled/enabled?


    uncomment or set:

    WaylandEnable=false in the:/etc/gdm3/custom.conf

    and reboot. Does this help?


    Hello, I confirm that the problem had to do with Wayland.

    Turning it off solved the problem for me.

    Thank you very much for your help!

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.