Cannot install NoMachine from deb or tar

Forum / NoMachine for ARM / Cannot install NoMachine from deb or tar

Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #43526
    Mysticle31
    Participant

    I cannot install NoMachine on Ubuntu Jammy Jellyfish (development branch) aarch64

    I get the error:

    It seems that you are trying to install this package in a directory without proper permissions. Please try to install it in a different
    directory or change permissions. The installation directory should
    have at least 555 permissions set.

    I’ve tried both the deb, user@localhost: ~/Downloads$ sudo dpkg -i nomachine_8.4.2_1_arm64.deb
    And the tarball extracted to the /usr folder: sudo /usr/NX/nxserver –install

     

    There is no log file that I can find anywhere.

    I found a closed trouble report from a couple versions ago…

    How do I install NoMachine? How do I investigate?

     

    #43557
    zaq
    Participant

    Hello Mysticle31,

    It looks like you have a problem with installation directory permissions /usr.
    They should look more or less like:

    drwxr-xr-x. 13 root root 226 Mar 22 14:16 usr

    #43579
    Mysticle31
    Participant

    That worked!  I had only 777’d the NX folder and didn’t consider the usr folder.

    NoMachine is installed.

    However, the server does not start.

    I can start the sever with nexserver –start at it will not report a problem.  Server started on port 4000.

    I can start the Server settings gui but on the bottom it flashes “Authentication failed. please try again.”

    Do I have more permissions issues?

    I checked the server log and find:

    Redis is now ready to exit, bye bye….

    ServerRedisServer: Cleaning up handler information.

    getMaxPIDLinux: ERROR! Cannot open ‘/proc/sys/kernel/pid max’ file.

    Unknown option: daemon

    NXSERVER WARNING! Process ‘/usr/NX/bin/nxexec /etc/NX/nxserver –daemon’ with pid ‘2856/2856’ finished with exit code 1

    NXSERVER WARNING! nxserver –deamon is not ready.

     

     

    #43667
    Britgirl
    Participant

    Which hardware platform are you installing the packages on? Raspberry Pi, something else?

    The version of ARM that you have installed, where did you get it from?

    Logs would be useful. We’ll need NoMachine logs from the device. Follow the instructions here: https://kb.nomachine.com/DT07S00243 and then submit them to forum[at]nomachine[dot]com using the topic’s title as the subject of your email. Thanks!

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.