Cannot run NX client in Fedora 25 beta

Forum / NoMachine for Linux / Cannot run NX client in Fedora 25 beta

Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #12873


    I installed NX 5.1.54_1 (64 bit) rpm in the latest Fedora 25 beta 64 (Gnome DE) bit running as a virtual machine in Fedora 24 64 bit. I was planning to use it as a client. While installing, it complained about “ERROR: Cannot enable systemd service: nxserver.service”.

    I tried running NX player via gnome’s menu and saw that it crashed with the following message in journalctl -b :
    Nov 12 23:22:03 localhost.localdomain audit[3954]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=3 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=3954 comm=”nxplayer.bin” exe=”/usr/NX/bin/nxplayer.b
    Nov 12 23:22:03 localhost.localdomain kernel: traps: nxplayer.bin[3954] trap divide error ip:7f65a5be3b30 sp:7ffee67f01e0 error:0 in[7f65a586e000+94b000]
    Nov 12 23:22:03 localhost.localdomain abrt-hook-ccpp[3956]: Process 3954 (nxplayer.bin) of user 1000 killed by SIGFPE – dumping core

    I also tried running it via terminal and it crashes there too with the message :
    “Floating point exception (core dumped).”

    Is this due to the fact that you support Fedora versions only up to 23, or is it because I am missing something ?
    Thanks for your help in advance.


    It’s a known problem. It’s appears on updated Fedora 25 BETA. NoMachine works fine on installed Fedora 25 BETA from the scratch.

    If you want to use NoMachine on your updated BETA, you need to disable SElinux. You can do it executing commands:

    sudo setenforce 0
    sudo /usr/NX/bin/nxserver --restart


    I can confirm that this issue got fixed without disabling SELinux, after I updated F25 beta to the latest (as of 20th Nov 2016) and NX client now runs without issues.


    So it’s a problem in earlier patches of Fedora’s beta which they already fixed in the latest patches of a couple of days ago.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.