Cannot share USB devices from Windows 10 to MacOs Sonoma

Forum / NoMachine for Mac / Cannot share USB devices from Windows 10 to MacOs Sonoma

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #46841
    BenjimiMac
    Participant

    NoMachine free version on Windows 10 – 8.10.1

    NoMachine free version on Mac Sonoma 14.0 –  8.10.1

    Not able to connect USB device from Windows 10 machine to Mac Mini running Sonoma 14.0. I have two Windows 10 machines. I can connect to/from either of those and share USB devices as expected. In my case it is Samsung and Apple phones. When I connect the devices to the either machine as a client it is fully visible in the server explorer and any IDEs that I choose to use for debugging. I can’t so same from either Windows machine to Mac Mini M1 running Sonoma 14.0. The devices show as connected in the NoMachine “Connected Devices” list and have a green dot next to them. On one of the Windows clients they even show up in the System Report “USB” section sometimes, but not all of the time (cannot reproduce either scenario with the System Report). But they are never visible in the list of connected devices in any IDE installed on the Mac. I’ve uninstalled and reinstalled. Uninstalled, removed any other third-party files relating to other USB/IP software, checked the permissions that NoMachine has on disk access. I can’t seem to get this to work. I’ve searched through the forums but can’t seem to find anyone that’s had this issue.

    Any help would be greatly appreciated.

    #46857
    Giorgi-G.
    Contributor

    Hi, could you try restarting both machines and forwarding a simple device like a USB Flash Drive or mouse/keyboard?

    Also, have you tried forwarding in a vice-versa direction? Is it working?

    #46942
    BenjimiMac
    Participant

    Hi Giorgi-G,

    Thank you for your reply. Sorry about the delay getting back to you. So I’ve had some substantial progress. I can share any device from the Mac back to Windows (import), and after going through all the steps and re-reading the knowledge base articles I discovered that AS Media was still installed on my Dell machine. After removing it I can now share an iPhone 7 and it operates correctly on the remote machine and is discoverable and can be selected as a debug device in an IDE, but none of my Samsung devices can be shared from Windows 10 to MacOs still, but I can import them from the Mac when plugged into it.

    When I plug any one of the Android devices directly into the Mac there are no issues. When I export them from Windows to Mac I initially get a pop-up on the devices asking to deny or allow the connected computer access. While this pop-up is on screen the device shows up in the System Report on Mac as an attached USB device. But when I select “allow” I can’t access it at all except for the System Report. It never shows up as a debug device in an IDE on the Mac. I’ve tried revoking the USB debugging authorisations on the Android, but this is still the case.

    So I have good progress that I can at least connect with the iPhone, but would obviously like to be able to connect the Android devices.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.