Cannot unlock screen (Ubuntu 19.10 Server, Windows 10 client)

Forum / NoMachine for Linux / Cannot unlock screen (Ubuntu 19.10 Server, Windows 10 client)

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #25195

    I am trying to connect to my Ubuntu 19.10 home-server from my Windows 10 machine. My initial problem required that the server be connected to a monitor for the NoMachine connection to work. I changed the /usr/NX/etc/node.cfg

    PhysicalDisplays :10

    I did this as it appeared to me that NoMachine was unable to create an XWindows session, or something to that nature. This change, if I understand correctly, allowed it to create its own XWindows session.

    I then discovered a new problem: If the machine timesout and locks the session, or if I manually lock it, it will not unlock. I can unlock it on the physical machine; however, my input will not unlock it. You can see that it is receiving input to the password dialogue, but it simply does not work. I’ve tried copying/pasting the password as well with the same results.

    I’m no expert, so my modification might be related to this problem, but then I am unable to use NoMachine at all in a headless environment. I wish to run a headless server ultimately, and use NoMachine for the rarer instances where I need a GUI.



    The problem here is a bit complicated. As you said, setting PhysicalDisplays key to ‘:10’ prevents the NoMachine from detecting your true desktop (which probably is on display :0, :1 or :1024 if you are using Wayland).

    Then, as you say NoMachine is creating its own Xserver and starting the session there.

    So now you have ‘physical session’ and ‘virtual session’ working on your system, so even when you unlock it on physical screen, it will not affect virtual.

    The problem is however with virtual session and lock screen. It is a known issue with the new way gnome handles the sessions, and how it interacts with NoMachine virtual sessions, and right now unfortunately there is no solution, except for disabling the lock screen on the virtual session.


Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.