Cannot update NoMachine server — update already running

Forum / NoMachine for Linux / Cannot update NoMachine server — update already running

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #16148

    This is in regard to forum post 15624, a report I made that I am unable to update NoMachine server because the user interface says “an update is already running”. The thread was closed because of my delay in responding (I apologize for that). Here’s the latest in that thread:

    We need to repeat the test with complete set of logs if you are still able to reproduce problem.

    Before testing please set in the NoMachine Player to not remove logs after quitting. To do that – open NoMachine Player -> navigate to “Settings” -> click on “Privacy” -> and check “Don’t delete log files on exit”.

    Second thing is to paste here also output of the command: cat /usr/NX/etc/server.cfg | grep UpdateFrequency.

    Now reproduce the problem and list all the NoMachine processes that appear using ps aux | grep nx >> nx_processes_list.txt . Repeat the grep at one minute intervals for three minutes, so we can compare the lists.

    Send created file with the three outputs to forum[at]nomachine[dot]com. Please zip and send also .nx folder.

    I have created the files you’ve requested and will shortly send them to the address above. The single zip file contains:

    * My console session log, which includes among other things the output of the gdb command you gave me before.
    * The UpdateFrequency value in the file nx_updatefreq.txt.
    * The process list at one-minute intervals for three minutes.
    * The .nx folder.

    I set the player to “save logs on exit” as you suggested. I assume I was supposed to do this on the server side.

    I’m not sure what you meant by “reproduce the problem”, though — the message about an update already running is in the Update Preferences dialog whenever it is showing. I made sure it was showing before running the test.

    I have not used the workaround you provided because I thought it would be better to fix the problem, and I was afraid that a manual update would mask it.

    I hope this is helpful… and again apologize for the delay. I will be more responsive to your next request.

    Derry Kabcenell


    Here’s the original link:

    We’ve received the logs 🙂


    Are you sure that system is rebooted. In received logs we can see processes started in June 16. Can you show output: who -b? Isn’t any minimized nxclient window on panel on any desktops? If you could not find any to fix problem kill process with number 8062 (root      8062  0.1  0.1 104180  8864 ?        Sl   Jun16 182:37 /usr/NX/bin/nxclient.bin –post progress –fd 4 –reopen).


    Thanks. You’re right, I hadn’t rebooted.

    I was prepared to send you another reproduction of the problem, but it occurred to me to try doing a check-for-update directly through the machine’s console, rather than using a NoMachine session. This check-for-update, and the subsequent update, were successful. I’m speculating that it was the running NoMachine session that was being complained about, not that a software update was running.

    On the other hand, I can now check for update just fine, using a NoMachine session. So I’m not sure what’s going on, but the problem appears fixed for now.

    Thanks for the help, and again I apologize for the long delays in responding. (For some reason, the forum is not sending me email when replies are posted, even though my profile settings appear to be set correctly.)



    Hi Derry, it seems the check box wasn’t flagged correctly for follow up notifications, although your profile is indeed configured to receive notifications.


    Thanks. I am getting the emails now.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.