Cant change desktop to lxde

Forum / General Discussions / Cant change desktop to lxde

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #15713

    WARNING: I know extremely little about linux; terminal, and enviroments, linux versions, etc. I am however very good with Windows based operating systems.

    My goal is to make the OS use the least amount of CPU and RAM (BUT still have a GUI).

    • I am renting a 1GB VPS Server.
    • The only option is to install Ubuntu Desktop OS.
    • The server does not have enough RAM & CPU power to handle the OS, with running programs that I need to use.
    • I need to change the OS, or streamline the OS so it uses the least amount of RAM & CPU.
    • I read online HERE ( how to change the “How to setup a lightweight desktop environment”. I googled lightweight desktops and found “LXDE” or “Lubuntu” would be a good choice since its a GUI and uses very little RAM & CPU. I tried to follow the instructions on the link above but it was to difficult to understand. I think I followed all the instructions correctly, but its not showing the new LDE desktop. I probably made a mistake somewhere.

    Anyways, I have no other option then to deal with linux, and I am hoping someone can help me figure out a solution to this problem. Once I manage to have a lightweight version of ubuntu, I will be perfect.

    Additional Questions

    1. Do you have any other suggestions on how to use as little RAM & CPU possible on ubuntu?

    2. Is there a better guide, tutorial or video out there that I can watch and learn how acheive this?

    3. Is there a script I can run to acheive this?

    4. Is there somehow an ability to install Ubuntu, then within being logged into ubuntu, erase the OS, and install Lubuntu instead? (essentially bypassing the restrictions from my VPS provider).


    Thank you so much for taking the time to read this! 🙂


    Open a terminal and execute commands:

    sudo apt-get install --reinstall lubuntu-desktop
    sudo apt-get autoremove --purge ubuntu-desktop

    First one is to install and switch to lubuntu, second one is to remove Unity desktop environment. To avoid having to set the NoMachine configuration files, the best thing to do is to remove NoMachine completely (sudo dpkg --purge nomachine && sudo rm -rf /usr/NX /etc/NX) and reinstall it.


    Thanks @kroy for your reply and easy instructions.

    I have entered all 3 commands but now I cannot login to the server.

    I am receiving the error code: “The NoMachine service is not available or the access was disabled”

    How do I connect to the server again?



    How do you re-install NoMachine using terminal?


    About those commands. First – installs lubuntu environment, second uninstalls Unity DE, that third one completely removes NoMachine from system. Did you install again NoMachine?


    All you need to know about installation, uninstalling, updating NoMachine is in the guide here:

    Section 4 is dedicated to Linux.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.