Can’t connect to Fedora 25 with NX 5.1.62

Forum / NoMachine for Linux / Can’t connect to Fedora 25 with NX 5.1.62

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #13230

    I recently installed NX 5.1.62 on a fedora 25 unix machine, and the installation seemed to go well. However, when I attempt to connect using a remote NoMachine client, the connection hangs.  It has not yet even timed out, so I can’t see the log file to see what is happening.  I’ve checked and the firewall is allowing connections on the port, the ip address is correct, and I’ve configured no machine to use the local user credentials.  Is there anything else I can try?  Happy to post any diagnostic information you request.

    Server: Fedora 25 running NX 5.1.62.  Gnome desktop (though it doesn’t get that far).  Server is running.

    Client: Mac OS X running NX 5.1.54.  Virtual display.


    Hi zemcov

    Maybe you have problem with the Fedora firewall – SElinux. You can try to set it on permissive mode just for test.

    Setting Selinux on permissive will disable SElinux, but everthing will still be logged into the SELinux log, which is in: /var/log/audit/audit.log .

    Command to set Selinux on permissive:

    setenforce 0

    To revert it back:

    setenforce 1

    To check Selinux status :


    You will need admin authorization to do this.

    It also would be nice if yoo tell me what connection are you trying to use: NX or SSH?


    Hi there – as a matter of fact I already did this and it had no effect.  I’ve tried both ssh and nx, but since I read that the free version of nx only allows nx connections I’ve concentrated on getting that working.

    As a matter of fact, when I try to connect with ssh the client says “this server does not support ssh, do you want to use nx?” (or words to that effect), I say yes, and it still hangs.  But I guess the good news is it’s connecting that much, at least.

    How do I turn on logging in the nx server?  I think I’d like to read the log files to see what the server things is going on.




    Hi zemcov,

    You can gather logs by following the procedure explained here:

    Best regards,


    OK, now we’re getting somewhere. Here’s what appears to be happening when I try to connect on the server side:

    2016-12-20 14:58:01 066.958  2897 NXSERVER User ‘user’ logged in from ‘’ using authentication method password.

    2016-12-20 14:58:02 947.124  2917 NXSERVER ERROR! Failed to determine the client IP

    2016-12-20 14:58:02 947.197  2917 NXSERVER ERROR! Variables NX_CONNECTION,SSH_CONNECTION,SSH_CLIENT,SSH2_CLIENT not provided.

    2016-12-20 14:58:02 947.242  2917 NXSERVER ERROR! Please set SSHDCheckIP=1 if you want to refuse the connection.

    2016-12-20 14:58:02 947.298  2917 NXSERVER ERROR! Failed to get remote port. Environment NX_CONNECTION,SSH_CONNECTION,SSH_CLIENT,SSH2_CLIENT not set

    2016-12-20 14:58:02 947.345  2917 NXSERVER ERROR! Failed to get local IP. Remote IP is 0.

    2016-12-20 14:58:02 950.343  2917 NXSERVER ERROR! Wrong process id, received pid 0.

    2016-12-20 14:58:02 950.399  2917 NXSERVER WARNING! Could not get SSHD PID: Process 0 does not have expected name.

    2016-12-20 14:58:02 952.279  2917 NXSERVER ERROR! Cannot save forward server pid. ‘value’ for key sshdPid cannot be null

    2016-12-20 14:58:04 035.445  2934 NXNODE   ERROR! Application terminated too early.

    2016-12-20 14:58:04 038.734  2917 NXSERVER ERROR! Sending error message ‘NX> 501 ERROR: Session failed, application terminated prematurely.’

    2016-12-20 14:58:04 069.697  2934 NXNODE   WARNING! NXClientMonitor: NXClientMonitor: NXClient –monitor is not running, can’t send message.

    2016-12-20 14:58:04 070.406  2934 NXNODE   Previous message repeated 8 times

    2016-12-20 14:58:04 070.489  2934 NXNODE   ERROR! NXClientMonitor: NXClient –monitor stopped during connection, can’t change monitor status.

    2016-12-20 14:58:04 070.862  2917 NXSERVER ERROR! Node reported monitor failure. Killing attached sessions.

    I’m not sure what the terminating error is, but the first complaint is that the server can’t determine the client’s IP, which is strange since it’s finding it correctly in the previous line (I’ve redacted my IP and set it to, but it appears correct in the original).  Any idea what the problem might be?


    Hi zemcov,

    According to logs that you have provided, we can see there is some problem with desktop on local server. We have got a topic with a very similar problem:


    Since it’s headless, can you make sure you followed the instructions outlined here?

    Link: .




    Ah!  That got it – all I had to do was install a desktop.  Stupid mistake.  Thanks a lot!

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.