Can’t connect to headless server using Windows 10

Forum / NoMachine for Linux / Can’t connect to headless server using Windows 10

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #24856

    I’m running windows  10 on local server and have been using [removed] for a while now. I’d like to switch back to NoMachine.  Remote server is running Ubuntu 16.04 and is fully up to date.

    I originally tried installing using deb manager, but that didnt’ work, so I switched over to the command line. Everything is installed on local/remote servers, but I cannot access the desktop for some odd reason. I’ve tried my root user, as well as a sudo user I’ve used for a while now.

    The instructions mention adding a user or changing the config file. I opted for the latter to no avail. I have no idea how to add a user because if I enter the command using “nxserver,” I keep seeing this annoying message that the command isn’t found.  That makes no sense to me because I can see it in /usr/NX/scripts/setup/nxserver and it’s executable.  I even changed the permission from 555 to 777 with no change. Unless I’m supposed to enter the command in a different folder?

    If I try to login with root or my sudo user I see the following error message “a configuration error has encountered. please contact your administrator.” I also user root has been connect, but it disappears very quickly. Absolutely no idea what that means. The screen is black and it shows an ok button to click. After clicking nomachine closes the session.

    My config file can be viewed here.

    I only uncommented a few lines.

    Running <span style=”color: #404040; font-family: Gudea, ‘AG Foreigner Light-Plain Medium’, sans-serif, sans-serif; font-size: 14px;”>ps -ef | grep X shows the folllowing </span>

    nx        2215     1  0 18:44 ?        00:00:00 /usr/NX/bin/nxserver.bin –daemon


    mysudousername+  4022     1  0 18:48 ?        00:00:11 x2goagent -nolisten tcp -nolisten tcp -dpi 96 -D -auth /home/mysudousername/.Xauthority -geometry 1400×750 -name X2GO-mysudousername-50-1576370925_stDXFCE_dp32 :50


    mysudousername+  4102     1  0 18:48 ?        00:00:00 /bin/bash /usr/bin/x2goruncommand 50 4022 mysudousername-50-1576370925_stDXFCE_dp32 47023 xfce4-session nosnd D


    mysudousername+  4237  4102  0 18:48 ?        00:00:00 /usr/bin/dbus-run-session /etc/x2go/Xsession


    mysudousername+  6926  6891  0 18:52 ?        00:00:24 java -Xmx256M -DfromWrapper -XX:TieredStopAtLevel=1 -noverify -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/config/logs -Xlog:gc*:file=../../config/logs/gclog-2019-12-14_18-52-16.log::filecount=10,filesize=5000 -Dspring.output.ansi.enabled=ALWAYS -jar /app/hydra2/lib/core-2.10.2-exec.jar –nobrowser –datafolder /config


    mysudouserhere+  9483     1  0 18:58 ?        00:00:06 /usr/lib/virtualbox/VBoxXPCOMIPCD


    root     12994     1  0 18:45 ?        00:00:03 /usr/NX/bin/nxserver.bin –upnpstatus


    nx       19154  2215  0 18:45 ?        00:00:00 /usr/NX/bin/nxd


    nx       24405 19154  0 19:35 ?        00:00:00 /usr/NX/bin/nxserver.bin -c /etc/NX/nxserver –login -H 4


    nx       24616  2215  0 19:35 ?        00:00:00 /usr/NX/bin/nxserver.bin –virtualsession –sessionid 2B795A3A2C1302ADE3DE35B5B9070585


    root     24631  2215  0 19:35 ?        00:00:00 /usr/NX/bin/nxexec –node –user root –priority realtime –mode 0 –pid 21


    root     24643 24631  0 19:35 ?        00:00:00 /usr/NX/bin/nxnode.bin


    root     24704 24643  0 19:35 ?        00:00:00 /usr/NX/bin/nxclient.bin -dialog ok -caption Error -message A configuration error has been encountered. Please contact your administrator. -class error -display :1001


    root     24730 24643  0 19:35 ?        00:00:00 /usr/NX/bin/nxclient.bin –monitor –pid 24704


    root     24886 24405  0 19:35 ?        00:00:00 /usr/NX/bin/nxexec –node –user root –priority realtime –mode 0 –pid 15 -H 4


    root     24898 24886  0 19:35 ?        00:00:00 /usr/NX/bin/nxnode.bin -H 4


    root     24989 24643  0 19:35 ?        00:00:00 /usr/NX/bin/nxcodec.bin


    root     25860 26944  0 19:37 pts/0    00:00:00 grep –color=auto X

    Looks like it’s an ongoing issue judging from the previous forum posts.

    Does anybody know how to fix this or where I should start to look for the root problem?





    First to clarify, when referring to the ‘nxserver’ command, on Linux systems by default the full
    path is either:




    Then to the problem itself. The popup window ‘A configuration error has been encountered. Please contact your administrator.’
    right now it can only be displayed during starting of a session when the ‘.ICEauthority’ file for the user that is starting
    session has wrong owner.

    You can confirm that this is the problem by checking the ‘/usr/NX/var/log/nxserver.log’ file.
    The warning too look for is:

    WARNING! The /root/.ICEauthority file has wrong ownership.

    If this is the case please make sure that the file noted in that warning has proper ownership set,
    in this case it should be:

    stat /root/.ICEauthority
    File: '/root/.ICEauthority'
    Access: (0600/-rw-------)  Uid: (    0/    root)   Gid: (    0/    root)

    If the access rights are wrong you can modify them by running:

    # chown root:root /root/.ICEauthority
    # chmod 0600 /root/.ICEauthority

    If this still does not help, please share any warnings/errors from ‘/usr/NX/var/log/nxserver.log’ and
    ‘/usr/NX/var/log/nxerror.log’ files.



    Thanks for the help Mth, your instructions worked perfectly!

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.