Сan’t install NoMachine 8

Forum / NoMachine for Linux / Сan’t install NoMachine 8

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #40209

    I tried to upgrade NoMachine from version 7 to 8.
    So firstly I removed NoMachine 7 and then installed NoMachine 8. But during installation I got an error:

    sudo dpkg -i nomachine_8.0.168_2_amd64.deb
    Selecting previously unselected package nomachine.
    (Reading database … 200850 files and directories currently installed.)
    Preparing to unpack nomachine_8.0.168_2_amd64.deb …
    Unpacking nomachine (8.0.168-2) …
    Replaced by files in installed package nomachine-enterprise-desktop (7.7.4-1) …
    Setting up nomachine (8.0.168-2) …
    /var/lib/dpkg/info/nomachine.postinst: line 7315: /usr/NX/scripts/setup/nxserver: No such file or directory
    dpkg: error processing package nomachine (–install):
    installed nomachine package post-installation script subprocess returned error exit status 127
    Errors were encountered while processing:


    The output you show indicates that NoMachine Free Edition for Linux (debian) was not uninstalled correctly using the recommended way, which is by using dpkg --purge. You probably just removed /usr/NX/ before uninstalling.

    To be able to install a new NoMachine package, you should also remove /etc/NX/ and /var/NX/ and try again from scratch.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.