Can’t resize Ubuntu remote server VMWare guest

Forum / NoMachine for Linux / Can’t resize Ubuntu remote server VMWare guest

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #6055

    I’m having trouble resizing the remote screen when using the NoMachine Desktop/free version. My local machine is a Windows 7 64bit laptop, the remote is a Kubuntu 14.04 64bit VMWare virtual machine running on an ESX server.  I have installed NoMachine 4.4.6 on both remote and local machines, and can connect using defaults for the NX protocol pretty well.  I can ramp up the quality of the display and the remote UI is still very interactive (much better than XRDP/X11RDP).  But, the remote screen is 800×600 resolution, and when I go to full screen, it does not resize the remote resolution as I would expect.

    I found another post which mentioned using xrandr to manually resize the screen.  Here is the output:

    Screen 0: minimum 1 x 1, current 1024 x 768, maximum 8192 x 8192

    Virtual1 connected primary (normal left inverted right x axis y axis)

    800×600        60.0 +   60.3

    1600×1200      60.0

    1680×1050      60.0

    1400×1050      60.0

    1280×1024      60.0

    1440×900       59.9

    1280×960       60.0

    1360×768       60.0

    1280×800       59.8

    1152×864       75.0

    1280×768       59.9

    1024×768       60.0

    640×480        59.9

    1904x1200_60.00   59.9

    Virtual2 disconnected (normal left inverted right x axis y axis)

    Virtual3 disconnected (normal left inverted right x axis y axis)

    Virtual4 disconnected (normal left inverted right x axis y axis)

    Virtual5 disconnected (normal left inverted right x axis y axis)

    Virtual6 disconnected (normal left inverted right x axis y axis)

    Virtual7 disconnected (normal left inverted right x axis y axis)

    Virtual8 disconnected (normal left inverted right x axis y axis)


    I added that last mode (1904×1200) based on running a cvt command, and knowing that my monitor supports that resolution, and that XRDP was able to put the remote X session in to that screen in the past.

    I can use “xrandr -s 1024×768” to get a better resolution, but when I go a bit further to 1600×1200, xrandr says the resolution is not supported:

    Size 1600×1200 not found in available modes

    …yet there it is in the output of “xrandr -q”.  I’ve tried the xrandr commands with sudo, to no avail.  I don’t believe that there is an xorg.conf file setup which would list modes for the screen, in my default Kubuntu installation, and I haven’t had to mess with that file in many years, anyway.  This Kubuntu install was done about 8 months ago.

    What could be the problem with NoMachine and the resolution changes?  Are there limitations connecting to ESX VMs with respect to resolution (doesn’t seem like other remote term/console protocols have an issue)?  What can I do to fix it (NoMachine is so far much more usable than other XRDP/VNC implementations I’ve tried)?





    This looks like a configuration problem on your server. NoMachine will only be able to set a resolution among the supported ones. If you are not able to set the given resolution even with the system xrandr command, NoMachine won’t be able to set it as well.

    You may try with the following command:

    xrandr –output Virtual1 –mode 1600×1200

    You may also check what resolutions are visible in the system settings menu, and if it is possible to set the wanted resolution there.


    I spent the day today creating a new VM with a more recent Ubuntu version (Kubuntu 15.04-alpha2), and which I haven’t put X11RDP onto (to avoid any conflicts).  The result is better.  But what looks like is happening, is the X Server is starting up with the “vmware” display driver, and the driver is not adding support for higher than 1366×768 resolution.  If I try to manually add any higher resolutions and use xrandr to switch to them, I get nasty and uninformative opcode errors from xrandr.  But, I can switch to 1366×768, at least.  After giving up on the antique ESX vmware-tools, I installed the open-vm-tools and open-vm-tools-desktop packages with apt-get.


    Ok, I figured it out.  In the VM configuration as accessed via VMWare vSphere Client (vCenter), the default behavior of a VM seems to be to cap the video memory at 4MB, which only allows so much resolution.  I had to power down the VM, then use vSphere Client to change the video memory of the VM to support my local monitor resolution (1920×1200), which is just under 8MB according to their calculator widget.

    Once I made that change, and booted the VM back up, NoMachine is able to automagically set the remote resolution (using xrandr or whatever) to support fullscreen on my local monitor.  In fact, it works better than RDP, which forces me to reconnect to my remote machine to change the resolution as viewed locally.

    The speed behind this protocol is really blazingly fast!  It was definitely worth the effort to get it going vs X11RDP.  But, I wish either the VMWare display driver, or xrandr, or NoMachine surfaced the reason better as to why the resolution wasn’t going any higher.  Probably all of those things need to change, which means they won’t.  If this phenomenon was documented in a FAQ or forum, then my first experience with NoMachine would have been a lot less painful.


    We will insert an article in the KB so that others like yourself can find it though. As an FYI, a similar topic was brought up here:

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.