Capture audio from server when Bluetooth headset used on server

Forum / NoMachine for Mac / Capture audio from server when Bluetooth headset used on server

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #46331
    nm.smayer97
    Participant

    Hello,

    I notice that when audio is streamed from the server to the client, NM only streams if sound is coming out through the local speaker. But if a bluetooth headset is connected to the server, the audio is no longer streamed. Is there a way to change this?

    Client Using:  iMac 2019 macOS 10.14 Mojave

    Server using: HP 15 laptop with Windows 10

    Using free NoMachine v8.8.1 on both server and client

     

    #46405
    kubaszym1
    Participant

    Hi,

    Do you mean that the headset is connected to the windows machine (server) – you can hear audio from Windows with this headset outside the session? I know you wrote it but I want to be sure. Do you connect the headset before or during the NoMachine session?

    If the bluetooth device is connected to the client machine, you should see it on the device list in NoMachine settings (click on right up corner of the NoMachine window, then go to Audio -> Change settings). You can set it as an output device on the client side.

    But if your headset is connected to the server, we will try to reproduce the issue and fix it.

    Regards,

    Kuba

    #46410
    nm.smayer97
    Participant

    Connection of the headset is on the server side.

    Connection can be before starting or during connection session. Same result… output sound is cut out.

    BTW, headset used is Bose Q45.

    #46440
    kubaszym1
    Participant

    Hi,

    You can check if you have “Exclusive mode” set for your headset. Exclusive mode is a feature that allows an application to get exclusive use of an audio device. It’s possible that turning it on (or off) for the bluetooth headset will make a difference. Go to Sound Control Panel, open “Device properties” of your headset, then go to “Advanced”. Then you can check/uncheck “Allow applications to take exclusive control of this device” in order to turn on/off the exclusive mode.

    Please let me know if you notice any difference during a NoMachine session.

    Regards,

    Kuba

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.