Centos 6 nx installation error (cannot add user: nx)

Forum / NoMachine for Linux / Centos 6 nx installation error (cannot add user: nx)

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #15586

    I’m working on a machine with Centos 6.9 64-bit. I had NoMachine installed in the past (the latest one I had was version 5.1), but I removed it. Now when I try to install newest version (nomachine_5.3.10_6_x86_64.rpm) I get an error (full log in attachment):

    ERROR: Cannot add user: nx to the system.

    Afterwards there are several more errors, but maybe this first one is the cause.

    The user nx doesn’t exist before running the installation (at least “id nx” and “userdel nx” return nothing). All old files (/usr/NX, /etc/NX/, /var/NX/) were removed before trying to install new version.

    Any help to resolve this would be appreciated.


    Hello Prymasze,

    We cannot see your logs, the upload failed.

    Could you please resend them to forum[at]nomachine[dot]com, with the topic’s subject as reference ?



    Do you use ActiveDirectory/LDAP/domain users?

    Could you send to us output from:

    1) id nx

    2) getent passwd nx

    3) /usr/sbin/useradd -d '/var/NX/nx' -p '*' -g nx -s /bin/false -r nx



    Yes, I use LDAP.

    Here are the outputs (all run as root):

    1. id: nx: No such user
    2. nothing is returned
    3. useradd: Invalid configuration: SYS_UID_MIN (201), UID_MIN (200), SYS_UID_MAX (199)
      useradd: can’t create user

    Following up on the error message from point 3 I added in /etc/login.defs


    Those are default values according to manual of /etc/login.defs. With this modification NX installs and works correctly. This behavior is a bit strange because I didn’t modify /etc/login.defs ever before, so the default values should be used from the start.

    Problem is solved, thank you for the help.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.